Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.
This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
Sample Input
95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12
Sample Output
548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201
Hint
If you don't know how to determine wheather encounted the end of input:
s is a string and n is an integer
s is a string and n is an integer
C++
while(cin>>s>>n)
{
...
}
c
while(scanf("%s%d",s,&n)==2) //to see if the scanf read in as many items as you want
/*while(scanf(%s%d",s,&n)!=EOF) //this also work */
{
...
}
--------------------------------------------------------------------
#include <stdio.h>
#define MAX 200 //按照本题的意思,只需用150个就够了
void power(int* a, int base, int n)
{
int i, j, set = 0;
memset(a, 0, sizeof(int)*MAX);//将a清零
for(i = 0, j=base; i<MAX; i++, j= j/10)
a[i] = j%10;
for(i=0; i<n-1; i++)
{
j = 0;
for(j=0; j<MAX; j++)
{
set = a[j]*base + set;
a[j] = set %10;
set = set/10;
}
}
}
int main(int argc, char **argv)
{
char s[MAX];
int a[MAX];
int n, i, base, len, k=0;
while(scanf("%s%d", s, &n)==2)
{
base = 0;
len = strlen(s);
for(i = 0; i < len; i++)//一直比较到len,增加了基数的范围
{
if(s[i]=='.')
{
k = len-(i+1);
continue;
}
base = base*10 + s[i]-'0';
}
printf("base: %d/n", base);
if (k != 0) //k==0表示输入的基数没有小数部分,可以正确计算20^2
{
for(i=(len-1); s[i]=='0'; i--, k--)
{
base = base/10;
}
k = k*n;
}
printf("base: %d/n", base);
power(a, base, n);
for(i=MAX-1; i>=0; i--)
{
if(a[i] != 0)
break;
}
//a[0] - a[k-1]为小数部分,所以至少应该从k-1处输出
if(i <= (k-1)) // <==> if(k>i)
{
printf(".");
for(i=k-1; i>=0; i--)
printf("%d", a[i]);
}
else
{
for(; i>=k; i--)
printf("%d", a[i]);
if( k != 0 )
printf(".");
for(; i>= 0; i--)
printf("%d", a[i]);
}
printf("/n");
}
return 0;
}
抄的别人的,但改了一小点。增加了点可用性。