uva-1588

Problem Background

A research laboratory of a world-leading automobile company has received an order to create a special transmission mechanism, which allows for incredibly efficient kickdown — an operation of switching to lower gear. After several months of research engineers found that the most efficient solution requires special gears with teeth and cavities placed non-uniformly. They calculated the optimal  flanks of the gears. Now they want to perform some experiments to prove their findings.

The first phase of the experiment is done with planar toothed sections, not round-shaped gears. A section of length n consists of n units. The unit is either a cavity of height h or a tooth of height 2 h. Two sections are required for the experiment: one to emulate master gear (with teeth at the bottom) and one for the driven gear (with teeth at the top).

There is a long stripe of width 3 h in the laboratory and its length is enough for cutting two engaged sections together. The sections are irregular but they may still be put together if shifted along each other.

The stripe is made of an expensive alloy, so the engineers want to use as little of it as possible. You need to  find the minimal length of the stripe which is enough for cutting both sections simultaneously.

Input

The input  file contains several test cases, each of them as described below.

There are two lines in the input, each contains a string to describe a section. The  first line describes master section (teeth at the bottom) and the second line describes driven section (teeth at the top). Each character in a string represents one section unit — 1 for a cavity and 2 for a tooth. The sections can not be  flipped or rotated.

Each string is non-empty and its length does not exceed 100.

Output

For each test case, write to the output a line containing a single integer number — the minimal length of the stripe required to cut off given sections.

Sample Input

2112112112
2212112
12121212
21212121
2211221122
21212

Sample Output

10
8
15

My Solution

#include <stdlib.h>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxlen 200

using namespace std;

//check if there's duplication between the two arrays
bool dup(int * a, int * b, int lena, int lenb){
    for(int i = 0; i < lena; i++){
        for(int j = 0; j < lenb; j++){
            if(a[i] < b[j]) break;
            if(a[i] == b[j]) return true;
        }
    }
    return false;
}

//add the value to all of the elements
void eleplus(int * arr, int val, int arr_num){
    for(int i = 0; i < arr_num; i++) arr[i] += val;
}

int main()
{
    char str_1[maxlen];
    int len_1;
    char str_2[maxlen];
    int len_2;
    int str_1_index[maxlen];
    int str_2_index[maxlen];

    while(scanf("%s %s", str_1, str_2)!=EOF){
        //counter of 2 in each array
        int counter1 = 0;
        int counter2 = 0;

        len_1 = strlen(str_1);
        len_2 = strlen(str_2);

        //make sure that string 1 not less than string 2
        if(len_1 < len_2) {
            swap(str_1, str_2);
            swap(len_1, len_2);
        }

        //find 2 in str_1
        for(int i = 0; i < len_1; i++)
            if(str_1[i] == '2') str_1_index[counter1++] = i;

        //find 2 in str_2
        for(int i = 0; i < len_2; i++)
            if(str_2[i] == '2') str_2_index[counter2++] = i;

        int len = 10000;
        eleplus(str_2_index, 0 - len_2, counter2);

        for(int i = 0 - len_2; i < len_1; i++){
            if(dup(str_1_index, str_2_index, counter1, counter2)){
                eleplus(str_2_index, 1, counter2);
                continue;
            }
            
            //update len
            int newlen;
            if(i < 0) newlen = len_1-i;
            else if(i < len_1 - len_2) newlen = len_1;
            else newlen = i + len_2;
            len = len > newlen ? newlen : len;
            
            if(len == len_1) break;
            eleplus(str_2_index, 1, counter2);
        }
        printf("%d\n", len);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值