UVA - 1588 Kickdown

A research laboratory of a world-leading automobile company has received an order to create a special transmission mechanism, which allows for incredibly efficient kickdown -- an operation of switching to lower gear. After several months of research engineers found that the most efficient solution requires special gears with teeth and cavities placed non-uniformly. They calculated the optimal flanks of the gears. Now they want to perform some experiments to prove their findings.

The first phase of the experiment is done with planar toothed sections, not round-shaped gears. A section of length n consists of n units. The unit is either a cavity of height h or a tooth of height 2h . Two sections are required for the experiment: one to emulate master gear (with teeth at the bottom) and one for the driven gear (with teeth at the top).

\epsfbox{p3712a.eps}

There is a long stripe of width 3h in the laboratory and its length is enough for cutting two engaged sections together. The sections are irregular but they may still be put together if shifted along each other.

\epsfbox{p3712b.eps}

The stripe is made of an expensive alloy, so the engineers want to use as little of it as possible. You need to �nd the minimal length of the stripe which is enough for cutting both sections simultaneously.

Input 

The input file contains several test cases, each of them as described below.

There are two lines in the input, each contains a string to describe a section. The first line describes master section (teeth at the bottom) and the second line describes driven section (teeth at the top). Each character in a string represents one section unit -- 1 for a cavity and 2 for a tooth. The sections can not be flipped or rotated.

Each string is non-empty and its length does not exceed 100.

Output 

For each test case, write to the output a line containing a single integer number -- the minimal length of the stripe required to cut off given sections.

Sample Input 

2112112112 
2212112 
12121212 
21212121 
2211221122 
21212

Sample Output 

10 
8 

15

假设固定装置s1,那么装置s2只要初始状态左端与s1左端对齐(该状态用偏移量k=0来标记),然后测试k=0时,两个装置是不是”每一位的和都不会超过3“就行了,如果不行就k++,继续往右边偏移进行测试。可以知道肯定存在着一个k能使其成立的(也就是s2左端接在s1右端时)。用这种方式遍历,找到的第一个可行解就是最佳解。 不过上述讨论还遗漏了一种组合方式,就是s2也可以往左偏移。其实将上述解法写成一个fun函数进行封装,外界(main函数)只要巧妙的利用对称性,就能重复利用上一段的代码了。

s1 左或右 s1 (←左移) 右移 s1 s1 左或右 s2

------- ---------- ---------- ---------- -----------

---------- ------------ ---------

s2 s2 s2

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;

bool test(int k,char s1[],char s2[]){
    for(int i = 0; s1[k+i] && s2[i]; i++)
        if(s1[k+i]+s2[i]-2*'0' > 3)return false;
    return true;
}

int fun(char s1[],char s2[]){
    int k = 0;
    while(!test(k,s1,s2))k++;
    return max(strlen(s1),strlen(s2)+k);
}

int main(){
    char bottom[105],top[105];
    while(scanf("%s%s",bottom,top) != EOF)//对称性
        cout<<min(fun(bottom,top),fun(top,bottom))<<endl;
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值