POJ 2488 A Knight's Journey

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, … , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, …

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input
3
1 1
2 3
4 3

Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4


  1. 题意:给你一个n*m的棋盘,要求你输出一条“骑士”行进的路径,使得其恰好经过棋盘上的每一个点。要求按照字典序输出最小的一条路径,无解输出impossible。
  2. 简单的dfs即可。每走一个格子就对其进行标记,注意在回溯的时候清除标记。
  3. 注意多case的情况下要清空各种数组。

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int n,m,pa_x[1000],pa_y[1000],xx[9]={0,-2,-2,-1,-1,1,1,2,2},yy[9]={0,-1,1,-2,2,-2,2,-1,1};
bool ok,b[30][30];
void dfs(int x,int y,int num)
{
    pa_x[num]=x;
    pa_y[num]=y;
    if(num==n*m)
        ok=1;
    b[x][y]=1;
    for(int i=1;i<=8;i++)
        if(x+xx[i]>=1&&x+xx[i]<=m&&y+yy[i]>=1&&y+yy[i]<=n&&!b[x+xx[i]][y+yy[i]]&&!ok)
            dfs(x+xx[i],y+yy[i],num+1);
    b[x][y]=0;
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int p=1;p<=t;p++)
    {
        ok=0;
        memset(b,0,sizeof(b));
        scanf("%d%d",&n,&m);
        printf("Scenario #%d:\n",p);
        for(int i=1;i<=m;i++)
            for(int j=1;j<=n;j++)
                if(!ok)
                    dfs(i,j,1);
        if(ok)
        {
            for(int i=1;i<=n*m;i++)
                printf("%c%d",pa_x[i]+'A'-1,pa_y[i]);
            printf("\n");
        }
        else
            printf("impossible\n");
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值