洛谷 P3093 [USACO13DEC]牛奶调度Milk Scheduling

题目描述

Farmer John has N cows that need to be milked (1 <= N <= 10,000), each of which takes only one unit of time to milk.

Being impatient animals, some cows will refuse to be milked if Farmer John waits too long to milk them. More specifically, cow i produces g_i gallons of milk (1 <= g_i <= 1000), but only if she is milked before a deadline at time d_i (1 <= d_i <= 10,000). Time starts at t=0, so at most x total cows can be milked prior to a deadline at time t=x.

Please help Farmer John determine the maximum amount of milk that he can obtain if he milks the cows optimally.

FJ有N(1 <= N <= 10,000)头牛要挤牛奶,每头牛需要花费1单位时间。

奶牛很厌烦等待,奶牛i在它的截止时间d_i (1 <= d_i <= 10,000)前挤g(1 <= g_i <= 1000)的奶,否则将不能挤奶。时间t开始时为0,即在时间t=x时,最多可以挤x头奶牛。

请计算FJ的最大挤奶量。
输入输出格式
输入格式:

Line 1: The value of N.
Lines 2..1+N: Line i+1 contains the integers g_i and d_i.

输出格式:

Line 1: The maximum number of gallons of milk Farmer John can obtain.

输入输出样例
输入样例#1:

4
10 3
7 5
8 1
2 1

输出样例#1:

25

说明

There are 4 cows. The first produces 10 gallons of milk if milked by time 3, and so on.

Farmer John milks cow 3 first, giving up on cow 4 since she cannot be milked by her deadline due to the conflict with cow 3. Farmer John then milks cows 1 and 2.


考虑贪心地选取,先选产奶量最大的,在截止日期挤,剩下的截止日期不能挤,就向前推。


#include<algorithm>
#include<iostream>
#include<cstdio>
using namespace std;
const int N=1e4+5;
int n,ans;
bool b[10004];
struct cow
{
    int dt,mlk;
}a[N];
bool cmp(cow c,cow d)
{
    return c.mlk>d.mlk;
}
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        scanf("%d%d",&a[i].mlk,&a[i].dt);
    sort(a+1,a+n+1,cmp);
    for(int i=1;i<=n;i++)
        for(int j=a[i].dt;j>=1;j--)
            if(!b[j])
            {
                ans+=a[i].mlk;
                b[j]=1;
                break;
            }
    printf("%d\n",ans);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值