HDOJ--1006

Tick and Tick

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15669    Accepted Submission(s): 3713


Problem Description
The three hands of the clock are rotating every second and meeting each other many times everyday. Finally, they get bored of this and each of them would like to stay away from the other two. A hand is happy if it is at least D degrees from any of the rest. You are to calculate how much time in a day that all the hands are happy.
 

Input
The input contains many test cases. Each of them has a single line with a real number D between 0 and 120, inclusively. The input is terminated with a D of -1.
 

Output
For each D, print in a single line the percentage of time in a day that all of the hands are happy, accurate up to 3 decimal places.
 

Sample Input
  
  
0 120 90 -1
 

Sample Output
  
  
100.000 0.000 6.251
 




这题我刚刚看见的时候感觉看不懂,有点不知所云,细读题发现这是一道秒,分,时针的追击问题,既然如此肯定就会涉及到角速度的问题。不得不说这题确实需要一定的数学能力,想了好久也做了好久。有ACM竞赛题的味道在里面。

关键:

①秒针6°/s;分针0.1°/s;时针1/120°/s。

②秒分时之间的角度关系:

秒:6*s

分:6*m+s*0.1;

时:30*h+0.5*m+s*1/120。

接下来就是边想边写代码了。以下是我的AC代码:

//杭电acm--1006
//Tick and Tick
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#define V_SEC 6.0
#define V_MIN 0.1
#define V_HOU 1.0/120.0
#define A_SEC s*6
#define A_MIN m*6+s*0.1
#define A_HOU h*30+m*0.5+s/120.0
using namespace std;
struct interval
{
    double l;
    double r;
  };
double Angle;
int s=0;
interval solve(double v,double a)
{
    interval p;
    if(v>0)
    {
        p.l=(Angle-a)/v;
        p.r=(360-Angle-a)/v;
    }
    else
    {
        p.l=(360-Angle-a)/v;
        p.r=(Angle-a)/v;
    }
    if(p.l<0)p.l=0;
    if(p.r>60)p.r=60;
    if(p.l>=p.r)p.l=p.r=0;
    return p;
}
interval intersection(interval a,interval b)
{
    interval p;
    p.l=max(a.l,b.l);
    p.r=min(a.r,b.r);
    if(p.l>=p.r)p.l=p.r=0;
    return p;
}
double happytime(int h,int m)
{
    double v_diff;
    double a_diff;
    interval str[3][2];
    interval s1;
    v_diff=V_HOU-V_MIN;
    a_diff=A_HOU-A_MIN;
    str[0][0]=solve(v_diff,a_diff);
    str[0][1]=solve(-v_diff,-a_diff);
    v_diff=V_MIN-V_SEC;
    a_diff=A_MIN-A_SEC;
    str[1][0]=solve(v_diff,a_diff);
    str[1][1]=solve(-v_diff,-a_diff);
    v_diff=V_HOU-V_SEC;
    a_diff=A_HOU-A_SEC;
    str[2][0]=solve(v_diff,a_diff);
    str[2][1]=solve(-v_diff,-a_diff);
    double result=0;
    for(int i=0;i<2;i++)
    for(int j=0;j<2;j++)
    for(int k=0;k<2;k++)
    {
        s1=intersection(intersection(str[0][i],str[1][j]),str[2][k]);
        result+=s1.r-s1.l;
    }
    return result;
}
int main()
{
    int h,m;
    while(scanf("%lf",&Angle)==1 && Angle!=-1)
    {
        double result=0;
        for(h=0;h<12;h++)
        {
            for(m=0;m<60;m++)
            {
                result+=happytime(h,m);
            }
        }
        printf("%.3lf\n",result*100/43200);
    }
    return 0;
}


当时AC时,大脑一片空白...

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值