HDOJ 1006 Tick and Tick

Problem Description
The three hands of the clock are rotating every second and meeting each other many times everyday. Finally, they get bored of this and each of them would like to stay away from the other two. A hand is happy if it is at least D degrees from any of the rest. You are to calculate how much time in a day that all the hands are happy.
 

Input
The input contains many test cases. Each of them has a single line with a real number D between 0 and 120, inclusively. The input is terminated with a D of -1.
 

Output
For each D, print in a single line the percentage of time in a day that all of the hands are happy, accurate up to 3 decimal places.
 

Sample Input
  
  
0 120 90 -1
 

Sample Output
  
  
100.000 0.000 6.251
//
//  main.cpp
//  1006
//
//  Created by 张嘉韬 on 16/2/17.
//  Copyright © 2016年 张嘉韬. All rights reserved.
//
改种方法并为解决这个问题,以后有时间再填坑
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
int d;
double trf(double a)
{
    if(a-180.0>0) return 360.0-a;
    else return a;
}
int func(int h1,int m1,int s1)
{
    double h,m,s,d1,d2,d3,r1,r2,r3;
    s=s1;
    m=m1+s1*(1.0/60.0);
    h=h1+m1*(1.0/60.0)+s1*(1.0/3600.0);
    d1=6.0*s;
    d2=6.0*m;
    d3=30.0*h;
    r1=trf(abs(d1-d2));
    r2=trf(abs(d1-d3));
    r3=trf(abs(d2-d3));
    if(r1-d>=0&&r2-d>=0&&r3-d>=0) return 1;
    else return 0;
}
int main(int argc, const char * argv[]) {
    while(scanf("%d",&d)==1&&d!=-1)
    {
        float counter=0;
        double res=0;
        int s,m,h;
        s=m=h=0;
        for(int i=1;i<=43200;i++)
        {
            s++;
            if(s==60)
            {
                m++;
                s=0;
                if(m==60)
                {
                    h++;
                    m=0;
                    if(h==12)
                        h=0;
                }
            }
            //if(i==43200) cout<<h<<" "<<m<<" "<<s<<endl;
            if(func(h,m,s)==1) {counter++;}
        }
        res=100*(counter/43200);
        printf("%.3f",res);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值