nyoj 412 bitset

The binary weight of a positive  integer is the number of 1's in its binary representation.for example,the decmial number 1 has a binary weight of 1,and the decimal number 1717 (which is 11010110101 in binary) has a binary weight of 7.Give a positive integer N,return the smallest integer greater than N that has the same binary weight as N.N will be between 1 and 1000000000,inclusive,the result is guaranteed to fit in a signed 32-bit interget.

输入
The input has multicases and each case contains a integer N.
输出
For each case,output the smallest integer greater than N that has the same binary weight as N.
样例输入
1717
4
7
12
555555
样例输出
1718
8
11
17
555557


bitset位运算。

b.any()

b中是否存在置为1的二进制位?

b.none()

b中不存在置为1的二进制位吗?

b.count()

b中置为1的二进制位的个数

b.size()

b中二进制位的个数

b[pos]

访问b中在pos处的二进制位

b.test(pos)

b中在pos处的二进制位是否为1

b.set()

b中所有二进制位都置为1

b.set(pos)

b中在pos处的二进制位置为1

b.reset()

b中所有二进制位都置为0

b.reset(pos)

b中在pos处的二进制位置为0

b.flip()

b中所有二进制位逐位取反

b.flip(pos)

b中在pos处的二进制位取反

b.to_ulong()

b中同样的二进制位返回一个unsigned long

os << b

b中的位集输出到


/*思路是从尾向头找,过程中累加1的个数n,找到第一个10,就变成01,
然后从尾开始把这部分之前的n个0变成1,剩下的写为0.*/
#include <stdio.h>
#include <bitset>
using namespace std; //注释部分是tle代码。
/*int count(int n) //求1的个数
{
    int sum = 0;
    while(n)
    {
        n = n & (n-1);
        sum++;
    }
    return sum;
}
int main()
{
    int i, n, cou, s;
    while(~scanf("%d", &n))
    {
        cou = count(n);
        //printf("%d\n", cou);
        for(i = n+1 ; ; i++)
        {
            s = count(i);
            if(s == cou)
            {
                printf("%d\n", i);
                break;
            }
        }
    }
    return 0;
}*/
int main()
{
    int i, j, cou, n;
    while(~scanf("%d", &n))
    {
        bitset<32>bt(n);
        cou = 0;
        for(i = 0 ; i < 32 ; i++)
        {
            if(bt[i])
                cou++;
            if(bt[i] && !bt[i+1])
            {
                bt[i] = 0;
                bt[i+1] = 1;
                j = i;
                break;
            }
        }
        cou--;
        for(i = 0 ; i < cou ; i++)
            bt[i] = 1;
        for(; i < j ; i++)
            bt[i] = 0;
        printf("%ld\n", bt.to_ulong());
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值