nyoj 18 triangle

The Triangle

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
输出
Your program is to write to standard output. The highest sum is written as an integer.
样例输入
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5
样例输出
30

这是第一次的代码。用了dp和a两个数组。其中a保存原始的数字阵,dp表示从某一点往下的最大的一条路径。用的是从下往上。

 
#include <stdio.h>
#include <algorithm>
using namespace std;
int a[105][105], dp[105][105];
int main()
{
    int n, i, j;
    scanf("%d", &n);
    for(i = 1 ; i <= n ; i++)
        for(j = 1 ; j <= i ; j++)
    {
        scanf("%d", &a[i][j]);
        dp[i][j] = a[i][j];
    }
    for(i = n-1 ; i >= 1 ; i--)
        for(j = 1 ; j <= i ; j++)
    {
        dp[i][j] = max(dp[i+1][j], dp[i+1][j+1]) + a[i][j];
    }
    printf("%d\n", dp[1][1]);
    return 0;
}
        

后来发现,这里的a根本用不到,完全可以用dp代替的。所以将a数组删掉,改成dp。优化了空间。

再后来参考了最优代码,发现其实可以一边输入一边进行运算,采用从上往下的思路。这时dp[i][j] = max(dp[i-1][j], dp[i-1][j-1]) + dp[i][j]。

#include <stdio.h>
#include <algorithm>
using namespace std;
int dp[105][105];
int main()
{
    int n, i, j;
    scanf("%d", &n);
    for(i = 1 ; i <= n ; i++)
        for(j = 1 ; j <= i ; j++)
    {
        scanf("%d", &dp[i][j]);
        dp[i][j] = max(dp[i-1][j], dp[i-1][j-1]) + dp[i][j];
    }
    int ans = -1;
    //for(i = 1 ; i <= n ; i++)
    ans = *max_element(dp[n], dp[n]+n);
    printf("%d\n", ans);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值