[bzoj2527][整体二分]Meteors

Description

Byteotian Interstellar Union (BIU) has recently discovered a new
planet in a nearby galaxy. The planet is unsuitable for colonisation
due to strange meteor showers, which on the other hand make it an
exceptionally interesting object of study. The member states of BIU
have already placed space stations close to the planet’s orbit. The
stations’ goal is to take samples of the rocks flying by. The BIU
Commission has partitioned the orbit into msectors, numbered from 1to
m, where the sectors 1and mare adjacent. In each sector there is a
single space station, belonging to one of the nmember states. Each
state has declared a number of meteor samples it intends to gather
before the mission ends. Your task is to determine, for each state,
when it can stop taking samples, based on the meter shower predictions
for the years to come. Byteotian Interstellar
Union有N个成员国。现在它发现了一颗新的星球,这颗星球的轨道被分为M份(第M份和第1份相邻),第i份上有第Ai个国家的太空站。
这个星球经常会下陨石雨。BIU已经预测了接下来K场陨石雨的情况。
BIU的第i个成员国希望能够收集Pi单位的陨石样本。你的任务是判断对于每个国家,它需要在第几次陨石雨之后,才能收集足够的陨石。 输入:
第一行是两个数N,M。 第二行有M个数,第i个数Oi表示第i段轨道上有第Oi个国家的太空站。
第三行有N个数,第i个数Pi表示第i个国家希望收集的陨石数量。 第四行有一个数K,表示BIU预测了接下来的K场陨石雨。
接下来K行,每行有三个数Li,Ri,Ai,表示第K场陨石雨的发生地点在从Li顺时针到Ri的区间中(如果Li<=Ri,就是Li,Li+1,…,Ri,否则就是Ri,Ri+1,…,m-1,m,1,…,Li),向区间中的每个太空站提供Ai单位的陨石样本。
输出: N行。第i行的数Wi表示第i个国家在第Wi波陨石雨之后能够收集到足够的陨石样本。如果到第K波结束后仍然收集不到,输出NIE。
数据范围: 数据范围: 1<=n,m,k<=3*10^5 1<=Pi<=10^9 1<=Ai<10^9

Input

The first line of the standard input gives two integers, n and
m(1<=n,m<=3*10^5) separated by a single space, that denote,
respectively, the number of BIU member states and the number of
sectors the orbit has been partitioned into. In the second line there
are mintegers Oi(1<=Oi<=n) separated by single spaces, that denote the
states owning stations in successive sectors. In the third line there
are nintegers Pi(1<=Pi<=10^9) separated by single spaces, that denote
the numbers of meteor samples that the successive states intend to
gather. In the fourth line there is a single integer k(1<=k<=3*10^5)
that denotes the number of meteor showers predictions. The following
klines specify the (predicted) meteor showers chronologically. The
i-th of these lines holds three integers Li, Ri, Ai(separated by
single spaces), which denote that a meteor shower is expected in
sectors Li,Li+1,…Ri (if Li<=Ri) or sectors Li,Li+1,…,m,1,…Ri (if
Li>Ri), which should provide each station in those sectors with
Aimeteor samples (1<=Ai<10^9). In tests worth at least 20% of the
points it additionally holds that .

Output

Your program should print nlines on the standard output. The i-th of
them should contain a single integer Wi, denoting the number of shower
after which the stations belonging to the i-th state are expected to
gather at least Pi samples, or the word NIE (Polish for no) if that
state is not expected to gather enough samples in the foreseeable
future.

Sample Input

3 5

1 3 2 1 3

10 5 7

3

4 2 4

1 3 1

3 5 2

Sample Output

3

NIE

1

题解

整体二分天数
然后还不是套路做吗.

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<cmath>
using namespace std;
typedef long long LL;
LL s[310000];
int n,m,T;
int lowbit(int x){return x&-x;}
void change(int x,LL c){while(x<=m)s[x]+=c,x+=lowbit(x);}
LL findsum(int x){LL ret=0;while(x>=1)ret+=s[x],x-=lowbit(x);return ret;}
//bit
int last[310000],nxt[310000];
struct node{int pos,tim;LL op;}q[910000],lq[910000],rq[910000];int ln;//值 时间 
struct qq{LL nd;int x;}w[310000],lw[310000],rw[310000];
int ans[310000];
LL SUM(int pos)
{
    LL ret=0;
    pos=last[pos];
    while(pos!=-1)
    {
        ret+=findsum(pos),pos=nxt[pos];
        if(ret>10000000000)break;
    }
    return ret;
}
void sol(int lval,int rval,int st,int ed,int gx,int gy)
{
    if(st>ed || gx>gy)return ;
    if(lval==rval)
    {
        for(int i=st;i<=ed;i++)change(q[i].pos,q[i].op);
        for(int i=gx;i<=gy;i++)
            if(SUM(w[i].x)>=w[i].nd)ans[w[i].x]=lval;
        for(int i=st;i<=ed;i++)change(q[i].pos,-q[i].op);
        return ;
    }
    int mid=(lval+rval)>>1;
    int lt=0,rt=0,wl=0,wr=0;
    for(int i=st;i<=ed;i++)
    {
        if(q[i].tim<=mid)change(q[i].pos,q[i].op),lq[++lt]=q[i];
        else rq[++rt]=q[i];
    }
    for(int i=gx;i<=gy;i++)
    {
        LL star=SUM(w[i].x);
        if(star>=w[i].nd)lw[++wl]=w[i];
        else w[i].nd-=star,rw[++wr]=w[i];
    }
    for(int i=ed;i>=st;i--)if(q[i].tim<=mid)change(q[i].pos,-q[i].op);
    for(int i=1;i<=lt;i++)q[i+st-1]=lq[i];
    for(int i=1;i<=rt;i++)q[i+st+lt-1]=rq[i];
    for(int i=1;i<=wl;i++)w[i+gx-1]=lw[i];
    for(int i=1;i<=wr;i++)w[i+gx+wl-1]=rw[i];
    sol(lval,mid,st,st+lt-1,gx,gx+wl-1);
    sol(mid+1,rval,st+lt,ed,gx+wl,gy);
}
int main()
{
    //freopen("a.in","r",stdin);
    //freopen("a.out","w",stdout);
    scanf("%d%d",&n,&m);
    memset(nxt,-1,sizeof(nxt));memset(last,-1,sizeof(last));
    for(int i=1;i<=m;i++)
    {
        int x;scanf("%d",&x);
        nxt[i]=last[x];last[x]=i;
    }
    for(int i=1;i<=n;i++)scanf("%lld",&w[i].nd),w[i].x=i;
    scanf("%d",&T);
    for(int i=1;i<=T;i++)
    {
        LL g;
        int l,r;scanf("%d%d%lld",&l,&r,&g);
        if(l<=r)
        {
            q[++ln].pos=l;q[ln].op=g;q[ln].tim=i;
            q[++ln].pos=r+1;q[ln].op=-g;q[ln].tim=i;
        }
        else
        {
            q[++ln].pos=l;q[ln].op=g;q[ln].tim=i;
            q[++ln].pos=1;q[ln].op=g;q[ln].tim=i;
            q[++ln].pos=r+1;q[ln].op=-g;q[ln].tim=i;
        }
    }
    memset(ans,-1,sizeof(ans));
    sol(1,T,1,ln,1,n);
    for(int i=1;i<=n;i++)
    {
        if(ans[i]==-1)printf("NIE\n");
        else printf("%d\n",ans[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值