[BZOJ2527]Poi2011-Meteors

[BZOJ2527]Poi2011-Meteors

题面

Description

Byteotian Interstellar Union (BIU) has recently discovered a new planet in a nearby galaxy. The planet is unsuitable for colonisation due to strange meteor showers, which on the other hand make it an exceptionally interesting object of study.

The member states of BIU have already placed space stations close to the planet's orbit. The stations' goal is to take samples of the rocks flying by. The BIU Commission has partitioned the orbit into msectors, numbered from 1to m, where the sectors 1and mare adjacent. In each sector there is a single space station, belonging to one of the nmember states.

Each state has declared a number of meteor samples it intends to gather before the mission ends. Your task is to determine, for each state, when it can stop taking samples, based on the meter shower predictions for the years to come.

Byteotian Interstellar Union有N个成员国。现在它发现了一颗新的星球,这颗星球的轨道被分为M份(第M份和第1份相邻),第i份上有第Ai个国家的太空站。

这个星球经常会下陨石雨。BIU已经预测了接下来K场陨石雨的情况。
BIU的第i个成员国希望能够收集Pi单位的陨石样本。你的任务是判断对于每个国家,它需要在第几次陨石雨之后,才能收集足够的陨石。
输入:
第一行是两个数N,M。
第二行有M个数,第i个数Oi表示第i段轨道上有第Oi个国家的太空站。
第三行有N个数,第i个数Pi表示第i个国家希望收集的陨石数量。
第四行有一个数K,表示BIU预测了接下来的K场陨石雨。
接下来K行,每行有三个数Li,Ri,Ai,表示第K场陨石雨的发生地点在从Li顺时针到Ri的区间中(如果Li<=Ri,就是Li,Li+1,...,Ri,否则就是Ri,Ri+1,...,m-1,m,1,...,Li),向区间中的每个太空站提供Ai单位的陨石样本。
输出:
N行。第i行的数Wi表示第i个国家在第Wi波陨石雨之后能够收集到足够的陨石样本。如果到第K波结束后仍然收集不到,输出NIE。

数据范围:
1<=n,m,k<=3*10^5
1<=Pi<=10^9
1<=Ai<10^9

Input

The first line of the standard input gives two integers, n and m(1<=n,m<=3*10^5) separated by a single space, that denote, respectively, the number of BIU member states and the number of sectors the orbit has been partitioned into.

In the second line there are mintegers Oi(1<=Oi<=n) separated by single spaces, that denote the states owning stations in successive sectors.

In the third line there are nintegers Pi(1<=Pi<=10^9) separated by single spaces, that denote the numbers of meteor samples that the successive states intend to gather.

In the fourth line there is a single integer k(1<=k<=3*10^5) that denotes the number of meteor showers predictions. The following klines specify the (predicted) meteor showers chronologically. The i-th of these lines holds three integers Li, Ri, Ai(separated by single spaces), which denote that a meteor shower is expected in sectors Li,Li+1,…Ri (if Li<=Ri) or sectors Li,Li+1,…,m,1,…Ri (if Li>Ri), which should provide each station in those sectors with Aimeteor samples (1<=Ai<10^9).

In tests worth at least 20% of the points it additionally holds that .

Output

Your program should print nlines on the standard output. The i-th of them should contain a single integer Wi, denoting the number of shower after which the stations belonging to the i-th state are expected to gather at least Pi samples, or the word NIE (Polish for no) if that state is not expected to gather enough samples in the foreseeable future.

Sample Input

3 5
1 3 2 1 3
10 5 7
3
4 2 4
1 3 1
3 5 2

Sample Output

3
NIE
1

Source

鸣谢 Object022

思路

首先看到这道题,发现是一个区间修改的操作。因为是环形,所以我们把环从M断开,断环为链,同时把每个包含M和1的操作拆成两个即可。

思考一下这道题的主体部分。“每个国家收集到足够陨石的次数”很显然可以使用二分法,判断固定波陨石雨后能不能完成收集。但是计算一下就会发现,对每个国家都进行二分时间复杂度会爆炸。同时我们发现对每个国家进行二分时,都要重新模拟k场陨石雨来计算答案,而这k场陨石雨是完全相同的。那我们就考虑使用整体二分。

整体二分陨石雨次数K,区间树状数组进行操作修改。每次修改之后直接暴力统计,如果没达到放左边,达到了放右边。树状数组查询复杂度\(O(\log _2n)\),每个国家的全部空间站在一次递归中只会被查询一次,所以每一“层”查询复杂度最高为\(O(m)\),一共有\(O(\log_2k)\),所以总复杂度是\(nlog^2n\)的。

代码

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
using namespace std;
#define maxn (int)(3e5+1000)
#define inf (int)(1e9+1000)
#define ll long long
int n,m,k,cnt;
struct gg{
    int lo,next;
}sta[maxn];
struct node{
    int l,r,a;
}met[maxn];
int head[maxn],p[maxn],q[maxn],q1[maxn],q2[maxn],ans[maxn];
ll c[maxn];
int low(int x){return x&-x;}
void add(int l,int r,int num){
    for(int i=l;i<=m;i+=low(i)){c[i]+=num;}
    for(int i=r+1;i<=m;i+=low(i)){c[i]+=-num;}
    return;
}
ll query(int x){
    ll tot=0;
    for(int i=x;i>=1;i-=low(i)){
        tot+=c[i];
    }
    return tot;
}
void solve(int l,int r,int L,int R){//l~r->meteor/L~R->country
    if(r<l||R<L){return;}
    if(l==r){
        for(int i=L;i<=R;i++){ans[q[i]]=l;}return;
    }
    int mid=(l+r)>>1;int cnt1=0,cnt2=0;
    for(int i=l;i<=mid;i++){
        if(met[i].l>met[i].r){
            add(met[i].l,m,met[i].a);
            add(1,met[i].r,met[i].a);
        }
        else{
        add(met[i].l,met[i].r,met[i].a);}
    }
    for(int i=L;i<=R;i++){
        ll tot=0;
        for(int j=head[q[i]];j;j=sta[j].next){
            tot+=query(sta[j].lo);
            if(tot>p[q[i]])break;
        }
        if(p[q[i]]<=tot){
            q1[++cnt1]=q[i];
        }
        else{p[q[i]]-=tot;q2[++cnt2]=q[i];}
    }
    for(int i=l;i<=mid;i++){
        if(met[i].l>met[i].r){
            add(met[i].l,m,-met[i].a);
            add(1,met[i].r,-met[i].a);
        }
        else{
        add(met[i].l,met[i].r,-met[i].a);}
    }
    for(int i=1;i<=cnt1;i++){q[L+i-1]=q1[i];}
    for(int i=1;i<=cnt2;i++){q[L+cnt1+i-1]=q2[i];}
    solve(l,mid,L,L+cnt1-1);solve(mid+1,r,L+cnt1,R);
    return;
}
int main(){
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++){
        int con;scanf("%d",&con);
        sta[++cnt]=(gg){i,0};sta[cnt].next=head[con];head[con]=cnt;
    }
    for(int i=1;i<=n;i++){scanf("%d",&p[i]);}
    scanf("%d",&k);
    for(int i=1;i<=k;i++){
        scanf("%d%d%d",&met[i].l,&met[i].r,&met[i].a);
    }
    met[++k].l=1;met[k].r=m;met[k].a=inf;
    for(int i=1;i<=n;i++)q[i]=i;
    solve(1,k,1,n);
    for(int i=1;i<=n;i++){
        if(ans[i]==k)printf("NIE\n");
        else printf("%d\n",ans[i]);
    }
    return 0;
}

转载于:https://www.cnblogs.com/GavinZheng/p/10917460.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值