BFS-POJ-3278-Catch That Cow

Catch That Cow
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17

Sample Output
4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

//
//  main.cpp
//  搜索6
//
//  Created by 袁子涵 on 17/3/6.
//  Copyright © 2017年 袁子涵. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <string>
#include <queue>
#include <vector>
#include <algorithm>
#include <cmath>
#include <set>
#include <list>
#include <map>
#include <stack>
using namespace::std;
const int maxn=100010;
bool vis[maxn*2];
queue<pair<int,int> >Q;
int main(int argc, const char * argv[]) {
    int s,t,now,step,ans;
    cin >> s >> t;
    if (s>t) {
        cout << s-t << endl;
        return 0;
    }
    Q.push(make_pair(s, 0));
    vis[s]=1;
    while (!Q.empty()) {
        now=Q.front().first;
        step=Q.front().second;
        Q.pop();
        if (now==t) {
            ans=step;
            break;
        }
        if (!vis[now+1]) {
            vis[now+1]=1;
            Q.push(make_pair(now+1, step+1));
        }
        if (now>0 && !vis[now-1]) {
            vis[now-1]=1;
            Q.push(make_pair(now-1, step+1));
        }
        if (now<maxn && !vis[now*2]) {
            vis[now*2]=1;
            Q.push(make_pair(now*2, step+1));
        }
    }
    cout << ans << endl;
    return 0;
}
下面是手写队列版
//
//  main.cpp
//  简单搜索-C-Catch That Cow
//
//  Created by 袁子涵 on 15/7/26.
//  Copyright (c) 2015年 袁子涵. All rights reserved.
//

#include <string.h>
#include <iostream>

#define minof(a,b)  ((a)>(b)?(b):(a))

using namespace std;

typedef struct node
{
    unsigned long int step;
    unsigned long int num;
}Node;

//队列
typedef struct queue
{
    unsigned long long int head;
    unsigned long long int tail;
    Node data[1000000];
}Queue;

unsigned long int N,K;
Queue q;
Node origin,final;
int map[1000010];

//初始化
void initqueue()
{
    q.head=0;
    q.tail=0;
}

//入队
void Enqueue(Node t)
{
    q.data[q.tail]=t;
    q.tail++;
}

//出队
Node Dequeue()
{
    return q.data[q.head++];
}

//判断空队列
int queueempty()
{
    if (q.head==q.tail) {
        return 0;
    }
    return 1;
}

//检查数范围
int checknum(unsigned long int a)
{
    if (a<=110000 && a>0 && map[a]==0) {
        return 1;
    }
    return 0;
}

void bfs()
{
    Node t,y;
    Enqueue(origin);
    while (queueempty()) {
        t=Dequeue();
        map[t.num]=1;
        if (t.num==final.num) {
            final.step=minof(final.step, t.step);
            break;
        }
        y.step=t.step+1;
        y.num=t.num+1;
        if (checknum(y.num)) {
            Enqueue(y);
        }
        y.num=t.num-1;
        if (checknum(y.num)) {
            Enqueue(y);
        }
        y.num=t.num*2;
        if (checknum(y.num)) {
            Enqueue(y);
        }
    }
}

int main()
{
    cin >> N >> K;
    initqueue();
    memset(map, 0, sizeof(map));
    origin.num=N;
    origin.step=0;
    final.step=100000;
    final.num=K;
    bfs();
    cout << final.step <<endl;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值