DFS-BZOJ-1619-[Usaco2008 Nov]Guarding the Farm 保卫牧场

Description

The farm has many hills upon which Farmer John would like to place guards to ensure the safety of his valuable milk-cows. He wonders how many guards he will need if he wishes to put one on top of each hill. He has a map supplied as a matrix of integers; the matrix has N (1 < N <= 700) rows and M (1 < M <= 700) columns. Each member of the matrix is an altitude H_ij (0 <= H_ij <= 10,000). Help him determine the number of hilltops on the map. A hilltop is one or more adjacent matrix elements of the same value surrounded exclusively by either the edge of the map or elements with a lower (smaller) altitude. Two different elements are adjacent if the magnitude of difference in their X coordinates is no greater than 1 and the magnitude of differences in their Y coordinates is also no greater than 1.

农夫JOHN的农夫上有很多小山丘,他想要在那里布置一些保镖(……)去保卫他的那些相当值钱的奶牛们。 他想知道如果在一座小山丘上布置一名保镖的话,他总共需要招聘多少名保镖。他现在手头有一个用数字矩阵来表示地形的地图。这个矩阵有N行(1 < N < = 100)和M列( 1 < M < = 70) 。矩阵中的每个元素都有一个值H_ij(0 < = H_ij < =10,000)来表示该地区的海拔高度。请你帮助他统计出地图上到底有多少个小山丘。 小山丘的定义是:若地图中一个元素所邻接的所有元素都比这个元素高度要小(或它邻接的是地图的边界),则该元素和其周围所有按照这样顺序排列的元素的集合称为一个小山丘。这里邻接的意义是:若一个元素与另一个横坐标纵坐标和它的横纵坐标相差不超过1,则称这两个元素邻接。 问题名称:guard 输入格式: 第一行:两个由空格隔开的整数N和M 第二行到第N+1行:第I+1行描述了地图上的第I行,有M个由空格隔开的整数:H_ij. 输入样例:(guard.in): 8 7 4 3 2 2 1 0 1 3 3 3 2 1 0 1 2 2 2 2 1 0 0 2 1 1 1 1 0 0 1 1 0 0 0 1 0 0 0 0 1 1 1 0 0 1 2 2 1 1 0 0 1 1 1 2 1 0 输出格式: 第一行:小山丘的个数 输出样例:(guard.out): 3 输出样例解释: 地图上有三个小山丘:每个小山丘的山峰位置分别在左上角(高度为4),右上角(高度为1)和底部(高度为2)。
Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2..N+1: Line i+1 describes row i of the matrix with M space-separated integers: H_ij
    Output

  • Line 1: A single integer that specifies the number of hilltops

Sample Input
8 7

4 3 2 2 1 0 1

3 3 3 2 1 0 1

2 2 2 2 1 0 0

2 1 1 1 1 0 0

1 1 0 0 0 1 0

0 0 0 1 1 1 0

0 1 2 2 1 1 0

0 1 1 1 2 1 0

Sample Output
3

HINT

三个山丘分别是:左上角的高度为4的方格,右上角的高度为1的方格,还有最后一行中高度为2的方格.


题解:
深度优先搜索,每次找到当前地图中最高的一点,并使Out++,然后DFS去将从这一点开始满足山丘边缘定义的点逐步DFS删去(可以是置零或是标记)。反复找新的最高点,直到没有点剩下或者是剩下的点为0。


//
//  main.cpp
//  搜索3
//
//  Created by 袁子涵 on 17/2/25.
//  Copyright © 2017年 袁子涵. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <string>
#include <queue>
#include <vector>
#include <algorithm>
#include <cmath>
#include <set>
#include <list>
#include <map>
#include <stack>
using namespace::std;
const int maxn=1005;
int n,m,maze[maxn][maxn];
int mv[8][2]={{-1,0},{1,0},{0,1},{0,-1},{-1,-1},{-1,1},{1,-1},{1,1}};
typedef struct node
{
    int x,y,h;
    bool operator <(const node &r)const
    {
        return h>r.h;
    }
}node;
node maze1[maxn*maxn];
bool vis[maxn][maxn];
bool check(int x,int y)
{
    if (x<0 || x>=n || y<0 || y>=m)
        return 0;
    return !vis[x][y];
}
void dfs(int x,int y)
{
    vis[x][y]=1;
    for (int i=0; i<8; i++) {
        int tmpx=x+mv[i][0],tmpy=y+mv[i][1];
        if (check(tmpx, tmpy) && maze[tmpx][tmpy]<=maze[x][y])
            dfs(tmpx, tmpy);
    }
    return;
}
int main(int argc, const char * argv[]) {
    int ans=0,total=0,now=0,x,y;
    cin >> n >> m;
    for (int i=0; i<n; i++)
        for (int j=0; j<m; j++)
        {
            cin >> maze[i][j];
            maze1[total].x=i,maze1[total].y=j;
            maze1[total].h=maze[i][j];
            total++;
        }
    sort(maze1+0, maze1+total);
    x=maze1[0].x,y=maze1[0].y;
    while (now!=total) {
        ans++;
        dfs(x,y);
        while (vis[maze1[now].x][maze1[now].y] && now<total) {
            now++;
        }
        x=maze1[now].x,y=maze1[now].y;
    }
    cout << ans << endl;
    return 0;
}
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <string>
#include <queue>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;
int n,m,maze[1005][1005];
typedef struct node
{
    int x,y,z;
    bool operator <(const node &r)const
    {
        return z>r.z;
    }
}node;
int tmpx,tmpy;
int moved[8][2]= {{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};
bool check(int x,int y)
{
    if(x<0 || x>=n || y<0 || y>=m)
        return 0;
    return 1;
}
bool vis[1005][1005];
int main()
{
    cin >> n >> m;
    long long int out=0,now=0;
    vector<node>Node;
    node tmp;
    for(int i=0; i<n; i++)
        for(int j=0; j<m; j++)
        {
            scanf("%d",&maze[i][j]);
            Node.push_back(node{i,j,maze[i][j]});
        }
    queue<node>q;
    sort(Node.begin(),Node.end());
    tmp=Node[0];
    vis[tmp.x][tmp.y]=1;
    q.push(tmp);
    now++;
    while(tmp.x!=n)
    {
        out++;
        while(!q.empty())
        {
            tmp=q.front();
            q.pop();
            for(int i=0; i<8; i++)
            {
                tmpx=tmp.x+moved[i][0],tmpy=tmp.y+moved[i][1];
                if(check(tmpx,tmpy))
                    if(maze[tmpx][tmpy]<=tmp.z && maze[tmpx][tmpy]!=0 && vis[tmpx][tmpy]==0)
                    {
                        q.push(node{tmpx,tmpy,maze[tmpx][tmpy]});
                        vis[tmpx][tmpy]=1;
                    }
            }
        }
        tmp.x=n;
        for(long long int i=now;i<n*m;i++)
        {
            if(vis[Node[i].x][Node[i].y]==0)
            {
                if(Node[i].z==0)
                    break;
                tmp=Node[i];
                now=i;
                break;
            }
        }
        q.push(tmp);
        vis[tmp.x][tmp.y]=1;
    }
    cout << out << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值