BFS-POJ-3126-Prime Path

Prime Path
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input
3
1033 8179
1373 8017
1033 1033
Sample Output
6
7
0

水题,从要求最短步数就能知道是BFS,可以选择先打1000到9999之间的素数表,利于多组数据的测试,也可以直接在BFS中判断是否是素数,要注意的是题中说明了开头数字不为0.

//
//  main.cpp
//  简单搜索-F-Prime Path
//
//  Created by 袁子涵 on 15/8/2.
//  Copyright (c) 2015年 袁子涵. All rights reserved.
//

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

int n,m;
int a,b;
bool visit[10000];

typedef struct data
{
    int num;
    int step;
}Data;

typedef struct queue
{
    int head,tail;
    Data data[10000];
}Queue;

Queue q;

void initqueue()
{
    q.head=0;
    q.tail=0;
}

bool prime(int digit)
{
    if(digit==2 || digit==3)
        return true;
    else if(digit<=1 || digit%2==0)
        return false;
    else if(digit>3)
    {
        for(int i=3;i*i<=digit;i+=2)
            if(digit%i==0)
                return false;
    }
    return true;
}

bool emptyqueue()
{
    if (q.head==q.tail) {
        return 0;
    }
    return 1;
}

void bfs()
{
    int t;
    int k;
    int x,y;
    initqueue();
    memset(visit, 0, sizeof(visit));
    q.data[q.tail].num=a;
    q.data[q.tail++].step=0;
    visit[a]=1;
    while (emptyqueue()) {
        t=q.data[q.head].num;
        if (t==b) {
            m=q.data[q.head].step;
        }
        x=t%10;
        y=t-x;
        for (int i=1; i<10; i+=2) {
            if (i==x) {
                continue;
            }
            k=y+i;
            if (prime(k) && visit[k]==0) {
                q.data[q.tail].num=k;
                q.data[q.tail++].step=q.data[q.head].step+1;
                visit[k]=1;
            }
        }
        if (x%2!=0) {
            x=(t%100)/10;
            y=t-x*10;
            for (int i=0; i<10; i++) {
                if (i==x) {
                    continue;
                }
                k=y+i*10;
                if (prime(k) && visit[k]==0) {
                    q.data[q.tail].num=k;
                    q.data[q.tail++].step=q.data[q.head].step+1;
                    visit[k]=1;
                }
            }
            x=(t/100)%10;
            y=t-x*100;
            for (int i=0; i<10; i++) {
                if (i==x) {
                    continue;
                }
                k=y+i*100;
                if (prime(k) && visit[k]==0) {
                    q.data[q.tail].num=k;
                    q.data[q.tail++].step=q.data[q.head].step+1;
                    visit[k]=1;
                }
            }
            x=t/1000;
            y=t%1000;
            for (int i=1; i<10; i++) {
                if (i==x) {
                    continue;
                }
                k=i*1000+y;
                if (prime(k) && visit[k]==0) {
                    q.data[q.tail].num=k;
                    q.data[q.tail++].step=q.data[q.head].step+1;
                    visit[k]=1;
                }
            }
        }
        q.head++;
    }
}

int main(int argc, const char * argv[]) {
    cin >> n;
    while (n--) {
        cin >> a >> b;
        bfs();
        cout << m << endl;

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值