DFS-HDU-1241-Oil Deposits

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18633 Accepted Submission(s): 10736

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ‘*’, representing the absence of oil, or ‘@’, representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
* @* @*
* * @* *
* @* @*
1 8
@@* * * * @*
5 5
* * * *@
* @@*@
* @* *@
@@@*@
@@**@
0 0

Sample Output
0
1
2
2

当初刚进软协的时候一个学长拿这个题考过我,当时只会C基础语法的我硬是憋了一个DFS出来,凑活着水吧。

//
//  main.cpp
//  简单搜索-L-Oil Deposits
//
//  Created by 袁子涵 on 15/8/17.
//  Copyright (c) 2015年 袁子涵. All rights reserved.
//

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>

using namespace::std;
int mv[8][2]={{-1,0},{1,0},{0,-1},{0,1},{-1,-1},{-1,1},{1,-1},{1,1}};
const int maxn=105;
bool vis[maxn][maxn],maze[maxn][maxn];
int n,m,ans;
bool check(int x,int y)
{
    if (x<0 || x>=n || y<0 || y>=m)
        return 0;
    return maze[x][y];
}
void dfs(int x,int y)
{
    if (vis[x][y])
        return;
    vis[x][y]=1;
    for (int i=0; i<8; i++)
        if (check(x+mv[i][0], y+mv[i][1]))
            dfs(x+mv[i][0], y+mv[i][1]);
    return;
}
int main(int argc, const char * argv[]) {
    while (cin >> n >> m && n && m) {
        memset(vis, 0, sizeof(vis));
        memset(maze, 0, sizeof(maze));
        ans=0;
        char c;
        for (int i=0; i<n; i++) {
            for (int j=0; j<m; j++) {
                cin >> c;
                if (c=='@')
                    maze[i][j]=1;
            }
        }
        for (int i=0; i<n; i++) {
            for (int j=0; j<m; j++) {
                if (maze[i][j] && !vis[i][j]) {
                    ans++;
                    dfs(i,j);
                }
            }
        }
        cout << ans << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值