打表-HDOJ-5347-MZL's chemistry

MZL’s chemistry

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 711 Accepted Submission(s): 496

Problem Description
MZL define F(X) as the first ionization energy of the chemical element X

Now he get two chemical elements U,V,given as their atomic number,he wants to compare F(U) and F(V)

It is guaranteed that atomic numbers belongs to the given set:{1,2,3,4,..18,35,36,53,54,85,86}

It is guaranteed the two atomic numbers is either in the same period or in the same group

It is guaranteed that x≠y

Input
There are several test cases

For each test case,there are two numbers u,v,means the atomic numbers of the two element

Output
For each test case,if F(u)>F(v),print “FIRST BIGGER”,else print”SECOND BIGGER”

Sample Input
1 2
5 3

Sample Output
SECOND BIGGER
FIRST BIGGER

直接打表。。。太水了不说了。

//
//  main.cpp
//  150804-1005
//
//  Created by 袁子涵 on 15/8/4.
//  Copyright (c) 2015年 袁子涵. All rights reserved.
//

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>

using namespace std;

int a,b;

int s[25]={0,1312,2372,520,899,800,1086,1402,1313,1681,2080,495,737,577,786,1011,999,1251,1520,1140,1351,1008,1170,890,1037};

int main(int argc, const char * argv[]) {
    while (scanf("%d %d",&a,&b)!=EOF) {
        if (s[a]>s[b]) {
            printf("FIRST BIGGER\n");
        }
        else
        {
            printf("SECOND BIGGER\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值