HDOJ-----5344---MZL's xor---思维

MZL's xor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1279    Accepted Submission(s): 795


Problem Description
MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all ( Ai + Aj )( 1i,jn )
The xor of an array B is defined as B1 xor B2 ...xor Bn
 

Input
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
Each test case contains four integers: n , m , z , l
A1=0 , Ai=(Ai1m+z) mod l
1m,z,l5105 , n=5105
 

Output
For every test.print the answer.
 

Sample Input
  
  
2 3 5 5 7 6 8 8 9
 

Sample Output
  
  
14 16
给出A1,以及Ai的通项 Ai=(Ai1m+z) mod  l ,可以求出数列A,求所有的(Ai+Aj)^(Ap+Aq)                    0 < i,j,p,q <= n

      A1     A2

A1   1       2

A2   2       3

首先考虑上面这个表的性质,对角线两侧完全对称即会出现(A1+A2)^(A2+A1)

考虑异或的性质,二进制位相同为0,不同为1,a^a = 0

所以求所有的(Ai+Aj)^(Ap+Aq),对角线两侧对称,全部抵消为0,最终是求对角线(Ai+Ai)^(A(i+1)+A(i+1))^ …… ^(An+An)

最终即2*(Ai ^ …… ^ An)

#include<cstdio>
#include<iostream>
#include<cstring>
#define LL long long
using namespace std;
int main(){
	int t, n, m, z, l;
	cin >> t;
	while(t--){
		cin >> n >> m >> z >> l;
		LL a, ans;
		ans = a = 0;
		for(int i = 0; i < n; i++){
			ans ^= a;
			a = (a*m+z)%l;
		}
		cout << 2*ans << endl;
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值