Uva-122 - Trees on the level(二叉树与set)

 Trees on the level 

Background

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.

This problem involves building and traversing binary trees.

The Problem

Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.

For example, a level order traversal of the tree 

picture28

is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specifiedif every node on all root-to-node paths in the tree is given a value exactly once.

The Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

The Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed.

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete
 
给定一个二叉树序列,你要写一个程序将每棵树按层序访问并打印出来。在这个问题中,二叉树的每个节都值都为正整数,且每棵树的节点数都小于256。

在层序遍例一个树时,指定行中所有的结点应按照从左至右的顺序打印,并且在第k行打印完之后才能打印第k+1行。

在本问题中,二叉树是由一系列的二元组(n, s)给出的,其中n是节点的值,s是由根到该节点的路径字符串。路径字符串由一系列的“L”和“R”组成,L代表左子树,R代表右子树。在上图所示二叉树中,值为13的节点由(13, RL)表示,值为2的节点由(2, LLR)表示。根节点由(5,)表示,其中空的路径字符串表示的路径就是由根到根。当一个二叉树中,所有从根到节点(已给出的)的路径上的所有的节点都已给出且只给出一次,那么这个二叉树就认为是完整的定义。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>

using namespace std;
int head=1,addp=1;
struct point
{
    int index;
    int value;
    bool have_va;
    point():have_va(false){}//that's the constructor(to initialize the variable)
    bool operator < (const point &a)const//it will instruct how to order the set
    {
        return a.index>index;//that's the asc order
    }
};

set<point>a;
set<point>::iterator it;//this is a pointer
char s[300];
int num=0;
bool addpoint(int va,char* po)
{
    int i;
    point ap;
    i=0;
    addp=1;
    while(po[i]!=')')
    {
        if(po[i]=='R')
            addp=addp*2+1;
        else if(po[i]=='L')
            addp=addp*2;
        num=max(num,addp);
        i++;
    }
    ap.index=addp;
    it=a.find(ap);
    if(it==a.end())
    {
        ap.value=va;
        ap.have_va=true;
        a.insert(ap);
        return true;
    }
    else
        return false;
}

int main()
{
    int st=0;
    num=0;
    while(scanf("%s",s)!=EOF)//must code like this,unless it will be runtime error
    {
        if(strcmp(s,"()"))
        {
        int va;
        char* po;
        sscanf(&s[1],"%d",&va);
        po=strchr(s,',')+1;
        if(!addpoint(va,po))
             st=1;
        }
        else
        {
        it=a.end();
        it--;
        while(it!=a.begin())
        {
            int w=it->index;
            point aa;
            aa.index=w/2;
            if(a.find(aa)==a.end())//can't find the root of the point
                st=1;
            it--;
        }
        if(it->index!=1)//notice that the first point may be not the root
            st=1;
       if(st==1)
       {
           printf("not complete\n");
           //continue;
       }
        else
            {
        auto tail=a.end();
        tail--;
        it=a.begin();
         while(it!=tail)
    {
         printf("%d ",it->value);
         it++;
    }
    
        printf("%d\n",tail->value);
            }
        a.clear();
        st=0;
        num=0;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值