uva 10137 The Trip

Description

A number of students are members of a club that travels annually to exotic locations. Their destinations in the past have included Indianapolis, Phoenix, Nashville, Philadelphia, San Jose, and Atlanta.
This spring they are planning a trip to Eindhoven. The group agrees in advance to share expenses equally, but it is not practical to have them share every expense as it occurs. So individuals in the group pay for particular things, like meals, hotels, taxi rides, plane tickets, etc. After the trip, each student’s expenses are tallied and money is exchanged so that the net cost to each is the same, to within one cent. In the past, this money exchange has been tedious and time consuming. Your job is to compute, from a list of expenses, the minimum amount of money that must change hands in order to equalize (within a cent) all the students’ costs.

Input

Standard input will contain the information for several trips. The information for each trip consists of
a line containing a positive integer, n, the number of students on the trip, followed by n lines of input,
each containing the amount, in dollars and cents, spent by a student. There are no more than 1000
students and no student spent more than $10,000.00. A single line containing 0 follows the information
for the last trip.

Output

For each trip, output a line stating the total amount of money, in dollars and cents, that must be
exchanged to equalize the students’ costs.

Sample Input

3
10.00
20.00
30.00
4
15.00
15.01
3.00
3.01
0

Sample Output

$10.00
$11.99

//
//  main.cpp
//  PC_test
//
//  Created by liuyuhan on 17/2/20.
//  Copyright (c) 2017年 liuyuhan. All rights reserved.
//

/*
 the money has all been spent.
 the output is the whole money that is received or given.
                  ---------------------- up
                  |    _________________
 -----------------|----|                 aver-pay(supposed)
                  |
 _________________|                      down
 一定要保证退的钱(up)比补的钱(down)少,所以给多的人给被告知有比aver高0.01的支出,以此来弥补当初对aver下取整时造成的空缺,当空缺补足时,就把多余的钱退还给剩下的给多的人。这个空缺被花费出去,没有得到给少的人的补给。
 除不开的钱(小数点后两位之后)被一部分给的多的人假装平摊掉了(假设他们的支出比别人多一分钱),这部分人被少退了一些钱。
 这样可以使得 补给的钱 >= 退掉的钱

*/
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <math.h>

using namespace std;

int main(int argc, const char * argv[]) {
    int n; // the number of persons
    //cout << (int)99.5 << endl;
    while(cin >> n) {
        if (n == 0)
            break;
        int i; // the index of student
        double hand[1001]; // the list of money every student hands up
        double sum = 0; // the sum of money
        double aver; // the average of money
        double up = 0; // the sum of upper
        int count = 0;
        //double res; // result;
        for (i = 0; i < n; i ++)
        {
            cin >> hand[i];
            sum += hand[i];
        }
        aver = ((int)((sum / n) * 100))/100.0;
        for (i = 0; i < n; i ++)
        {
            if (aver + 0.01 < hand[i]) {
                up += hand[i] - aver - 0.01;
                count ++;
            }
        }

        if (0.01 * count > sum - aver * n)
            up += 0.01 * count - (sum - aver * n);

        printf("$%.2f\n", up);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值