A1046 Shortest Distance (20分)【C语言】

A1046 Shortest Distance (20分)【C语言】

原题链接

题目给出了一个环形线路,环形线路上有N个出口,相邻两个出口间的距离已给出,每次只能移动到相邻出口。给出两个出口,问所需路程最短是多少。
要判断逆时针走还是顺时针走长度最短。dist[]数组表示从1到i顺时针方向下一个出口的距离;A[]数组表示相邻两个出口间的距离,则i,j两点顺时针方向的距离可以用dist[j-1]-dist[i-1]表示,最终距离只需判断(总距离-(dist[j-1]-dist[i-1]))与dist[j-1]-dist[i-1]中 较小的一个即可
还需要注意输入的始终点可能逆向,需要交换两者的值

题目描述:
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入格式:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10 ​5]), followed by N integer distances D​1​​ D​2​​ ⋯ DN , where D​i​​ is the distance between the i-th and the (i+1)-st exits,and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M(≤10 ​4), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10 ​7

输出格式:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

输入样例:

5 1 2 4 14 9
3
1 3
2 5
4 1

​​输出样例:

3
10
7

实现代码:

#include <stdio.h>

#define MaxSize 100001

int main()
{
	int A[MaxSize]={0}, dist[MaxSize]={0};
	int N, i, sum=0;
	scanf("%d", &N);
	for(i=1; i<=N; ++i){
		scanf("%d", &A[i]);
		sum += A[i];
		dist[i] = sum;
	}
	int n, L, R, t, min;
	scanf("%d", &n);
	for(i=0; i<n; ++i){
		scanf("%d %d", &L, &R);
		if(L>R){
			t = L;
			L = R;
			R = t;
		}
		min = dist[R-1]-dist[L-1];
		if(sum-min<min) min = sum - min;
		printf("%d\n", min);
	}
	
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值