A1012 The Best Rank (25分)【C语言】

A1012 The Best Rank (25分)【C语言】

原题链接

晴神…

题目描述:
To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

输入格式:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

输出格式:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

输入样例:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

输出样例:

1 C
1 M
1 E
1 A
3 A
N/A

实现代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;

struct Student{
	int id;
	int grade[4];
}stu[2010];

char course[4] = {'A', 'C', 'M', 'E'};
int Rank[10000000][4] = {0}; //Rank[id][0]~Rank[id][3]为4门课对应的排名 
int now; // cmp函数中使用,表示当前按now号分数排序stu数组 

bool cmp(Student a, Student b){ //stu数组按now号分数递减排序 
	return a.grade[now]>b.grade[now];
}

int main()
{
	int n, m, i;
	scanf("%d %d", &n, &m);
	// 读入分数,其中grade[0]~grde[3]分别代表A、C、M、E
	for(i=0; i<n; ++i){
		scanf("%d %d %d %d", &stu[i].id, &stu[i].grade[1], &stu[i].grade[2], &stu[i].grade[3]); 
		stu[i].grade[0] = round(stu[i].grade[1]+stu[i].grade[2]+stu[i].grade[3]);
	}
	for(now=0; now<4; ++now){ // 枚举A、C、M、E中的任意一个 
		sort(stu, stu+n, cmp); //对所有考生按照该成绩从大到小排序 
		Rank[stu[0].id][now] = 1; //排序完,将分数最高的设为rank1 
		for(i=1; i<n; ++i){ //对于剩下的考生 
			if(stu[i].grade[now] == stu[i-1].grade[now]){	
			Rank[stu[i].id][now] = Rank[stu[i-1].id][now]; //如果与前一位老生成绩相同,则他们排名相同 
			}else{
			Rank[stu[i].id][now] = i + 1; //否则,设置正确的排名 
			}
		}
	}
	int query; //查询考生的ID
	for(i=0; i<m; ++i){
		scanf("%d", &query);
		if(Rank[query][0]==0){ //如果这个考生id不存在 
			printf("N/A\n");
		}else{
			int j, k=0; //选出Rank[query][0~3]中最小的(Rank值越小,排名越高) 
			for(j=0; j<4; ++j){
				if(Rank[query][j]<Rank[query][k]) k=j;
			}
			printf("%d %c\n", Rank[query][k], course[k]);
		}
	} 
	
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值