A1067 Sort with Swap(0, i) (25分)【C语言】

A1067 Sort with Swap(0, i) (25分)【C语言】

原题链接

如果当前0位于i号位上,则将0和i交换位置,将0交换至i所在位置;
如果此时0回到了本位,则将其与最小的一个还未归位的数交换

题目描述:
Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

输入格式:
Each input file contains one test case, which gives a positive N (≤10 ​5​​ ) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.

输出格式:
For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

输入样例:

10
3 5 7 2 6 4 9 0 8 1

输出样例:

9

实现代码:

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 100010;

int main()
{
	int n, i, ans=0; //ans表示交换次数 
	int pos[maxn]; //存放各数字当前所处位置编号 
	scanf("%d", &n);
	int left=n-1, num; //left存放除0外不在自己位置上的数的个数 
	for(i=0; i<n; ++i){
		scanf("%d", &num);
		pos[num] = i; //num所处位置为i 
		if(num==i &&num!=0) left--;
	}
	int k=1; //存放除0之外当前不在本位上的最小的数
	while(left>0){
		if(pos[0]==0){ //0在本位上时 
			while(k<n){
				if(pos[k]!=k){
					swap(pos[0], pos[k]);
					ans++;
					break;
				}
				k++;
			}
		}
		while(pos[0]!=0){ //0不在本位上时 
			swap(pos[0], pos[pos[0]]);
			ans++;
			left--;
		}
	} 
	printf("%d", ans);
	
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值