【PAT】1067 Sort with Swap(0, i) (25 分)

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤10​5​​) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

 思路:

1、对每一个输入序列建立一个数组table,存储对应元素在输入序列中的下标,相当于是输入序列的下标指针,原理参考表排序,table[ input[i] ] = i

2、数组table中有三种类型的环,

      1) 已经放在正确位置上的,只有单个元素,不需要交换位置(单元环)

      2) 一个包含n0个元素的环,包含0,交换n0-1次(多元环)

      3) 第i个环包含ni个元素,不包含0,交换ni+1次(多元环)

设共有N个元素,有S个单元环,K个多元环,则交换次数为n0-1+ \sum_{i=1}^{k-1}(ni+1)   =  \sum_{i=0}^{k-1}ni+K-2 = N-S+K-2

这里有两种特殊情况要考虑,全部是单元环的情况,和只有1、3种环的情况

#include<stdlib.h>
#include<stdio.h>
#define MaxSize 100002

void InsertSort(int key[], int table[], int N) {
	int i,j,temp;
	for(i=1;i<N;i++) {
		j=i;
		for(temp=table[j];j>0&&key[temp]<key[table[j-1]];j--)
			table[j]=table[j-1];
		
		table[j]=temp;	
	}	
}

int main() {
	int num,i,temp,index,flag,S=0,K=0;
	int key[MaxSize],table[MaxSize];
	scanf("%d",&num);
	for(i=0;i<num;i++) {
		scanf("%d",&key[i]);
		if(key[i]==i)
			S++;
		
		table[key[i]]=i;   //相当于InsertSort的作用了
	}
	//InsertSort(key,table,num);  //很傻的用了排序,会超时,完全没必要,因为数据都是从0~N-1的
	
	for(i=0;i<num;i++) {
		index=i;
		flag=0;
		while(table[index]!=index) {
			temp=table[index];
			table[index]=index;
			index=temp;
			flag=1;
		}
		if(table[index]==index&&flag)
			K++;
		
	}
	if(num==S)   //特殊情况:全是单元环
		printf("0");
	else if(key[0]==0)   //特殊情况:只有1、3种环
		printf("%d",num-S+K);
	else
		printf("%d",num-S+K-2);
	
	//system("pause");
	return 0;
}

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值