A1047 Student List for Course (25分)【C语言】
题目描述:
Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.
输入格式:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.
输出格式:
For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.
输入样例:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5
输出样例:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
实现代码:
#include <cstdio>
#include <vector>
#include <algorithm>
#include <cstring>
using namespace std;
const int N = 40010;
const int M = 2510;
char name[N][5]; //char[i]表示第i个姓名
vector<int> course[M]; //course[i]存放选第i门课程的学生编号
bool cmp(int a, int b){
return strcmp(name[a], name[b])<0; //用字符串的下标代替字符本身进行排序
}
int main()
{
int n, k, c, courseID;
scanf("%d%d", &n, &k); //学生总数、课程总数
for(int i=0; i<n; ++i){ //对于每一个学生
scanf("%s%d", name[i], &c); //学生姓名、选课数
for(int j=0; j<c; ++j){ //对于该学生选的每一门课
scanf("%d", &courseID);
course[courseID].push_back(i); //将学生i加入课程courseID门课中
}
}
for(int i=1; i<=k; ++i){
printf("%d %d\n", i, course[i].size()); //第i门课的学生数
sort(course[i].begin(), course[i].end(), cmp); //对第i门课的学生姓名按字典序排序
for(int j=0; j<course[i].size(); ++j){
printf("%s\n", name[course[i][j]]);
}
}
return 0;
}