PAT 甲级 1047 Student List for Course(学生课程表)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

题意:输入学生数,课程数,输入学生的名字,所选科目数,所选科目编号(编号从1开始),要输出科目的编号,所选人数,选这个科目人的名字;

思路:可以用char数组形成映射,其下标代表学生的编号(相当于给所有学生编号),char的值即为学生的名字,所以有char name[maxn][5];

用动态数组vector的下标表示每个科目的编号,然后在这个科目后面push_back()学生的编号,我们就可以通过学生的编号,利用name来输出选这个课的学生;

注意点:在vector v[i].push_back(),有v[i][j],j是从0开始放的,所以遍历它的时候j=0开始遍历;

代码:

#include<iostream>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn=4010;
char name[maxn][5];//名字的长度为4,开5,人数最大为maxn;
bool cmp(int a,int b){
	return strcmp(name[a],name[b])<0;//输入的参数是要排序的参数,根据return 的内容排序; 
}
int main(){
	int n,m; 
	scanf("%d %d",&n,&m);
	vector<int > v[n+1];//因为是编号是从1开始的,所以要n+1,v的用处是在下标为i,存储学生的编号; 
	for(int i=0;i<n;i++){
		int seletnum,course;
		scanf("%s %d",name[i],&seletnum);//学生姓名和选的科目数; 
		for(int j=0;j<seletnum;j++){
			scanf("%d",&course);//所选科目的编号; 
			v[course].push_back(i);
		}
	}
	for(int i=1;i<=m;i++){
		sort(v[i].begin(),v[i].end(),cmp);
		printf("%d %d\n",i,v[i].size());
		for(int j=0;j<v[i].size();j++){
			printf("%s\n",name[v[i][j]]);//根据编号找名字; 
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值