1052 Linked List Sorting (25 point(s)) - C语言 PAT 甲级

1052 Linked List Sorting (25 point(s))

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [-105, 105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

题目大意:

给一个链表,输入 N 个节点和头结点地址,节点结构为 Address Key Next,按照 Key 的值对此链表升序排序,

输出排序后的节点数,头结点地址和链表节点

设计思路:
  • 利用结构体数组储存节点,数组索引当作地址
  • 从头结点遍历链表,并把节点地址按序存储在另一个地址数组中,同时记录有效节点总数
  • 根据节点 Key 值,对地址数组排序
  • 排序后按照要求输出

注:

  • 可能存在无效节点
  • 除 -1 外的有效地址,均要补 0 输出
  • 此链表为空时,输出 “0 -1”,表示节点数为 0,头结点为 -1,无节点需要输出
编译器:C (gcc)
#include <stdio.h>

struct node {
        int val, next;
};

struct node nodes[100000] = {0};

int cmp(const void *a, const void *b)
{
        return nodes[*(int *)a].val - nodes[*(int *)b].val;
}

int main(void)
{
        int addrs[100000] = {0}, count = 0;
        int n, head;
        int a, b, c;
        int i;

        scanf("%d %d", &n, &head);
        for (i = 0; i < n; i++) {
                scanf("%d %d %d", &a, &b, &c);
                nodes[a].val = b;
                nodes[a].next = c;
        }
        for (i = head; i != -1; i = nodes[i].next) {
                addrs[count] = i;
                count++;
        }

        if (count) {
                qsort(addrs, count, sizeof(addrs[0]), cmp);
                printf("%d %05d\n%05d %d ", count, addrs[0], addrs[0], nodes[addrs[0]].val);
                for (i = 1; i < count; i++) {
                        printf("%05d\n%05d %d ", addrs[i], addrs[i], nodes[addrs[i]].val);
                }
                printf("-1\n");
        } else {
                printf("0 -1\n");
        }

        return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值