(hdu2588)GCD(欧拉函数)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2320 Accepted Submission(s): 1174

Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

Output
For each test case,output the answer on a single line.

Sample Input
3
1 1
10 2
10000 72

Sample Output
1
6
260

题意:两个整数N,M,问有多少个X满足条件1<=X<=N且gcd(X,N)>=M

分析:可以直接用欧拉函数求解

#include<cstdio>
#include<cmath>
using namespace std;
int Euler(int n)///欧拉函数求小于等于n的正整数中有多少个数与n互质
{
    int s=n,i;
    for(i=2; i<=sqrt(n); i++) 
    if(n%i==0)
        {
            s=s/i*(i-1);
            while(n%i==0) n/=i;
        }
    if(n>1) s=s/n*(n-1);
    return s;
}
int main()
{
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        if(m==1) {printf("%d\n",n);continue;}
        int num=0;
        for(int i=2; i*i<=n; i++)
        {
            if(n%i==0) //i是n的因子
            {
                if(i>=m)
                    num+=Euler(n/i);
                if(i*i!=n)///避免重复计算n/i的欧拉函数所求值
                {
                    if(n/i>=m)
                        num+=Euler(n/(n/i));
                }
            }
        }
        printf("%d\n",num+1);///+1是因为有一个满足条件的数是n本身
    }
    return 0;
}

可以用容斥原理写? 我试了,时间超限,用队列和二进制位实现容斥原理都会TLE。。 递归?
先把代码放上来吧。。

#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
typedef long long LL;
int n,m;
LL gcd(LL a,LL b)
{
    return b?gcd(b,a%b):a;
}
LL lcm(int m,int n)
{
    return m/gcd(m,n)*n;
}
int solve()
{
    if(m==1) return n;
    vector<int>g;
    int i,j;
    for(int i=1; i<=n; i++)
    {
        if(n%i==0)
        {
            if(i>=m)
                g.push_back(i);
            if(n/i>=m)
                g.push_back(n/i);
        }
    }
    sort(g.begin(),g.end());
    int cnt=1;
    for(i=1; i<g.size(); i++)
    {
        for(j=0; j<i; j++)
            if(g[i]%g[j]==0)
                break;
        if(j==i)
            g[cnt++]=g[i];
    }
    int sum=0;
    for(int k=1; k<(1<<cnt); k++)
    {
        int mul=1,num=0;
        for(int i=0; i<cnt; i++)
        {
            if(k&(1<<i))
            {
                num++;
                mul=lcm(mul,g[i]);
            }
        }
        if(num&1) sum+=n/mul;
        else sum-=n/mul;
    }
    return sum;
    /* LL sum=0,front=0;
    LL k,que[N],t,tmp;
    que[front++]=-1;
    for(LL i=0; i<cnt; i++)
    {
        k=front;
        for(LL j=0; j<k; j++)
        {
            tmp=abs(que[j]);
            t=lcm(tmp,g[i]);
            que[front++]=t/que[j]*abs(que[j])*(-1);
        }
    }
    for(LL i=1; i<front; i++)
    {
        //printf("%d\n",que[i]);
        sum+=n/que[i];
    }
    return sum;*/
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        printf("%d\n",solve());
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值