poj 1019Number Sequence(数学 巧妙~~~)

Number Sequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37890 Accepted: 10952

Description

A single  positive (积极的)  integer (整数) i is given. Write a program to find the  digit (数字)  located (处于) in the position i in the  sequence (序列) of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the  input (投入) file contains a single  integer (整数) t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one  output (输出) line per test case containing the  digit (数字)  located (处于) in the position i.

Sample Input

2
8
3

Sample Output

2
2
#include<stdio.h>
#include<math.h>
unsigned int a[32000];
unsigned int s[32000];
void play_table()
{
    int i,j;
    a[1]=1;
    s[1]=1;
    for(i=2;i<32000;i++)
    {
        a[i]=a[i-1]+(int)log10((double)i)+1;
        s[i]=s[i-1]+a[i];

    }
}
int slove(unsigned n)
{
    int i=1;
    while(n>s[i]) i++;

    int pos = n-s[i-1];
    int len = 0;
    for(i=1;len<pos;i++)
        len+=(int)log10((double)i)+1;
    return (i-1)/(int)pow(10.0,len-pos)%10;
}
int main()
{
    unsigned n;
    int t,i,j;
    play_table();
    scanf("%d",&t);
    while(t--)
    {
        scanf("%u",&n);
        printf("%d\n",slove(n));
    }
}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值