Equal Sum Sets

Let us consider sets of positive integers less than or equal to n. Note that all elements of a set aredifferent. Also note that the order of elements doesnt matter, that is, both {3, 5, 9} and {5, 9, 3} meanthe same set.Specifying the number of set elements and their sum to be k and s, respectively, sets satisfying theconditions are limited. When n = 9, k = 3 and s = 23, {6, 8, 9} is the only such set. There may bemore than one such set, in general, however. When n = 9, k = 3 and s = 22, both {5, 8, 9} and {6, 7, 9}are possible.You have to write a program that calculates the number of the sets that satisfy the given conditions.InputThe input consists of multiple datasets. The number of datasets does not exceed 100.Each of the datasets has three integers n, k and s in one line, separated by a space. You may assume1 ≤ n ≤ 20, 1 ≤ k ≤ 10 and 1 ≤ s ≤ 155.The end of the input is indicated by a line containing three zeros.OutputThe output for each dataset should be a line containing a single integer that gives the number of thesets that satisfy the conditions. No other characters should appear in the output.You can assume that the number of sets does not exceed 231 − 1.Sample Input9 3 239 3 2210 3 2816 10 10720 8 10220 10 10520 10 1553 4 34 2 110 0 0Sample Output1202015425448100

#include<stdio.h>
#include<string.h>
int vis[50];
int cnt;
int n,s,k;
int vv[50];
int ff(int n)
{
    int sum=1;
    for(int i=1;i<=n;i++)
        sum*=i;
    return sum;
}
void bfs(int step,int sum,int j)
{

    if(step==k)
    {
        if(sum==s)
        {
            cnt++;
//
        }
        return;
    }
    if(sum>s||step>k)
         return;
    for(int i=j;i<=n;i++)
    {
        if(vis[i]==0)
        {
            vis[i]=1;
            vv[step]=i;
            bfs(step+1,sum+i,i+1);
            vis[i]=0;
        }
    }
}
int main()
{

    while(~scanf("%d%d%d",&n,&k,&s),n,k,s)
    {
        cnt=0;
        memset(vis,0,sizeof(vis));
        bfs(0,0,1);

        printf("%d\n",cnt);
    }
    return 0;
}

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
struct node
{
    int step;
    int id;
    int sum;
};

int cnt,n,k,s;
void bfs(int n,int k,int s)
{
   node a;
   int i,j;
   queue<node>q;
   for( i=1;i<=n;i++)
   {
        a.step=1;
       a.id=i;
       a.sum=i;
       q.push(a);
       while(!q.empty())
       {
           node t=q.front();
           q.pop();

           if(t.sum==s&&t.step==k)
           {
               cnt++;
           }


               for(j=t.id+1;j<=n;j++)
               {

                   {
                       node aa=t;
                   aa.step++;
                   aa.id=j;
                   aa.sum+=j;
                   q.push(aa);
                   }

               }


       }

   }

}
int main()
{

    while(~scanf("%d%d%d",&n,&k,&s),n,k,s)
    {
        cnt=0;

        bfs(n,k,s);

        printf("%d\n",cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
This is a MySQL query that selects the student ID (s_id), assigns a sequential number to each row (i), and calculates the rank of each student based on their sum of scores (sum_score). The query uses a subquery to first group the scores by student ID and calculate the sum of scores for each student. This subquery is then joined with a variable initialization subquery that sets the initial values of @k, @i, and @score to 0. The variable @k is used to keep track of the current rank while iterating over the rows. The variable @i is used to assign a sequential number to each row. The variable @score is used to compare the sum_score of the current row with the sum_score of the previous row. The CASE statement is used to check if the sum_score of the current row is equal to the sum_score of the previous row. If they are equal, then the rank remains the same. If they are not equal, then the rank is updated to the current sequential number. Here is a breakdown of the query: 复制 SELECT a.s_id, -- Select the student ID @i:=@i+1 AS i, -- Assign a sequential number to each row @k:=(case when @score=a.sum_score then @k else @i end) as rank, -- Calculate the rank a.sum_score AS score -- Select the sum of scores for each student FROM (SELECT s_id,SUM(s_score) AS sum_score FROM score GROUP BY s_id ORDER BY sum_score DESC) a, -- Subquery to calculate sum of scores for each student (SELECT @k:=0,@i:=0,@score:=0) s -- Subquery to initialize variables Note that the use of variables in this query is not recommended, as it can lead to unexpected results if the variables are not reset properly. It is better to use a subquery or a window function to calculate the rank. 翻译
最新发布
02-27

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值