L2-011. 玩转二叉树

L2-011. 玩转二叉树

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:
7
1 2 3 4 5 6 7
4 1 3 2 6 5 7
输出样例:
4 6 1 7 5 3 2
#include <bits/stdc++.h>
using namespace std;
struct node
{
    int data;
    struct node *l, *r;
};
int a[1000];
int cnt;
int pre[1100],in[1100];
struct node *creat(int *pre, int *in, int n)
{
    for(int i = 0; i < n; i++)
    {
        if(pre[0] == in[i])
        {
            struct node *t = new node;
            t->data = pre[0];
            t->l = creat(pre+1, in, i);
            t->r = creat(pre+i+1, in+i+1, n-(i+1));
            return t;
        }
    }
    return NULL;
};

void bfs(struct node *root)
{
    queue<node*>q;
    q.push(root);
    while(!q.empty())
    {
        node *now = q.front();
        q.pop();
        //printf("%d ",now->data);
        a[cnt++] = now->data;
        if(now->r != NULL)
        q.push(now->r);
        if(now->l != NULL)
        q.push(now->l);
    }
}
int main()
{
    int n;
    scanf("%d", &n);
    for(int i = 0; i < n; i++)
    {
        scanf("%d", &in[i]);
    }
    for(int i = 0; i < n; i++)
        scanf("%d", &pre[i]);

        struct node *root = creat(pre, in, n);
        cnt = 0;
        bfs(root);
        for(int i = 0; i <cnt - 1; i++)
            printf("%d ",a[i]);
        printf("%d\n",a[cnt-1]);

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值