是否完全二叉搜索树 (30分)

44 篇文章 0 订阅
23 篇文章 0 订阅


L3-010. 是否完全二叉搜索树

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

将一系列给定数字顺序插入一个初始为空的二叉搜索树(定义为左子树键值大,右子树键值小),你需要判断最后的树是否一棵完全二叉树,并且给出其层序遍历的结果。

输入格式:

输入第一行给出一个不超过20的正整数N;第二行给出N个互不相同的正整数,其间以空格分隔。

输出格式:

将输入的N个正整数顺序插入一个初始为空的二叉搜索树。在第一行中输出结果树的层序遍历结果,数字间以1个空格分隔,行的首尾不得有多余空格。第二行输出“YES”,如果该树是完全二叉树;否则输出“NO”。

输入样例1:
9
38 45 42 24 58 30 67 12 51
输出样例1:
38 45 24 58 42 30 12 67 51
YES
输入样例2:
8
38 24 12 45 58 67 42 51
输出样例2:
38 45 24 58 42 12 67 51
NO
//完全二叉树   若设二叉树的深度为h,除第 h 层外,其它各层 (1~h-1) 的结点数都达到最大个数,第 h 层所有的结点都连续集中在最左边,这就是完全二叉树。

#include <bits/stdc++.h>
using namespace std;
int n;
struct node
{
    int data;
    int id;
    struct node * l, *r;
};
struct node *creat(int x,struct node *root)
{
    if(root == NULL)
    {
        struct node *t;
        t= new node;
        t->data = x;
        t->l = t->r = NULL;
        return t;
    }
    if(root->data < x)
        root->l = creat(x, root->l);
    else root->r = creat(x, root->r);
    return root;

};
void in(struct node *root)
{
    if(root)
    {
        printf("%d ",root->data);
        in(root->l);

        in(root->r);
    }
}
int ff;
void bfs(struct node *root)
{
    queue<node *>q;
    root->id = 1;
    q.push(root);
    int flag = 0;
    while(!q.empty())
    {

        if(flag)
            printf(" ");
        struct node *now = q.front();
        q.pop();
        flag = 1;
        if(now->id > n)
            ff = 1;
        printf("%d",now->data);
        if(now->l != NULL)
        {
            now->l->id = now->id<<1;
            q.push(now->l);
        }

        if(now->r != NULL)
        {
            now->r->id = now->id<<1|1;
            q.push(now->r);
        }
    }
     printf("\n");
}
int main()
{
    struct node *root;
    root = new node;
    root = NULL;
    ff = 0;
    scanf("%d", &n);

    for(int i = 1; i <= n; i++)
    {
        int x;
        scanf("%d", &x);
        root = creat(x,root);
    }
    ff = 0;
    bfs(root);
    if(ff)
        printf("NO\n");
    else printf("YES\n");
}



评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值