数据结构实验之二叉树六:哈夫曼编码
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
字符的编码方式有多种,除了大家熟悉的ASCII编码,哈夫曼编码(Huffman Coding)也是一种编码方式,它是可变字长编码。该方法完全依据字符出现概率来构造出平均长度最短的编码,称之为最优编码。哈夫曼编码常被用于数据文件压缩中,其压缩率通常在20%~90%之间。你的任务是对从键盘输入的一个字符串求出它的ASCII编码长度和哈夫曼编码长度的比值。
Input
输入数据有多组,每组数据一行,表示要编码的字符串。
Output
对应字符的ASCII编码长度la,huffman编码长度lh和la/lh的值(保留一位小数),数据之间以空格间隔。
Sample Input
AAAAABCD
THE_CAT_IN_THE_HAT
Sample Output
64 13 4.9
144 51 2.8
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
priority_queue<int, vector<int>, greater<int> >q;
int main()
{
char s[50];
while(~scanf("%s", s))
{
int a[200] = {0};
for(int i = 0; i < strlen(s); i++)
{
a[s[i]]++;
}
for(int i = 0; i < 128; i++)
{
if(a[i])
{
q.push(a[i]);
}
}
int sum = 0;
while(q.size()>1)
{
int t1 = q.top();
q.pop();
int t2 = q.top();
q.pop();
sum += (t1+t2);
q.push(t1+t2);
}
int len =strlen(s);
printf("%d %d %.1lf\n",len*8,sum,len*8*1.0/sum);
q.pop();
}
return 0;
}