489 - Hangman Judge

 Hangman Judge 

In ``Hangman Judge,'' you are to write a program that judges a series of Hangman games. Foreach game, the answer to the puzzle is given as well as the guesses. Rules are the same as theclassic game of hangman, and are given as follows:

  1. The contestant tries to solve to puzzle by guessing one letter at a time.
  2. Every time a guess is correct, all the characters in the word that match the guess will be``turned over.'' For example, if your guess is ``o'' and the word is ``book'', then both ``o''s in thesolution will be counted as ``solved.''
  3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, whichneeds 7 strokes to complete. Each unique wrong guess only counts against the contestant once.

       ______   
       |  |     
       |  O     
       | /|\    
       |  |     
       | / \    
     __|_       
     |   |______
     |_________|
  4. If the drawing of the hangman is completed before the contestant has successfully guessed allthe characters of the word, the contestant loses.
  5. If the contestant has guessed all the characters of the word before the drawing is complete, thecontestant wins the game.
  6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

Your task as the ``Hangman Judge'' is to determine, for each game, whether the contestant wins,loses, or fails to finish a game.

Input

Your program will be given a series of inputs regarding the statusof a game. All input will be in lower case. The first line of each section will contain a number toindicate which round of the game is being played; the next line will be the solution to the puzzle;the last line is a sequence of the guesses made by the contestant. A round number of-1 would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

You win.
You lose.
You chickened out.

Sample Input

1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1

Sample Output

Round 1
You win.
Round 2
You chickened out.
Round 3
You lose.
  一个游戏,计算机给出一个字串让你猜,你每次可以猜一个字母。如果单词里有那个字母,所有该字母会显示出来;如果没有那个字母,则计算机会在一副“刽子手”画上填一笔。这幅画一共需要七笔就能完成,因此你最多只能错6次。注意,一个已经猜过的字母也算错。
  题目并没有难度,但码完后还是出现了bug,结合书本后,发现是考虑错了一种情况,即当计算机给出的字串全部猜对后,即可停止,并赢得比赛。改完后,提交AC。
  #include <stdio.h>
#include <string.h>
char s1[1000],s2[1000];
int left,chance;
int win,lose;
void guess(char ch)
{
	int p,i;
	p=1;
	for (i=0;i<strlen(s1);i++)
	  if (ch==s1[i]) 
	  {
	  	 s1[i]=' ';
	  	 p=0;
		 left--; 
	  }
	if (p==1) chance++;
	if (chance>6) lose=1;
	if (left==0)  win=1;    
}
int main()
{
	int len1,k,i;
	while (scanf("%d",&k)==1 && k!=-1)
	{
		scanf("%s",s1);
		scanf("%s",s2);
		chance=0;
		win=lose=0;
		printf("Round %d\n",k);
		left=strlen(s1);
		len1=strlen(s2);
		for (i=0;i<len1;i++)
		{
		  guess(s2[i]);
		  if (win || lose) break;
	    }
		if (lose) printf("You lose.\n");
		else
		 if (win) printf("You win.\n");
		  else
		   printf("You chickened out.\n");
		//printf("%d %d\n",left,chance);
		//printf("%s\n",s1);  
		memset(s1,0,sizeof(s1));
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值