Running Median POJ - 3784 动态求中位数-最大最小堆

Running Median

Description

For this problem, you will write a program that reads in a sequence of 32-bit signed integers. After each odd-indexed value is read, output the median (middle value) of the elements received so far.

Input

The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by an odd decimal integer M, (1 ≤ M ≤ 9999), giving the total number of signed integers to be processed. The remaining line(s) in the dataset consists of the values, 10 per line, separated by a single space. The last line in the dataset may contain less than 10 values.

Output

For each data set the first line of output contains the data set number, a single space and the number of medians output (which should be one-half the number of input values plus one). The output medians will be on the following lines, 10 per line separated by a single space. The last line may have less than 10 elements, but at least 1 element. There should be no blank lines in the output.

Sample Input

3
1 9
1 2 3 4 5 6 7 8 9
2 9
9 8 7 6 5 4 3 2 1
3 23
23 41 13 22 -3 24 -31 -11 -8 -7
3 5 103 211 -311 -45 -67 -73 -81 -99
-33 24 56

Sample Output

1 5
1 2 3 4 5
2 5
9 8 7 6 5
3 12
23 23 22 22 13 3 5 5 3 -3
-7 -3

动态输入求中位数

最大堆q2,最小堆q1;

q2中的元素个数始终比q1中的元素个数多1;

q1存放的元素都是>q2的堆顶元素。

不断维持这样的关系,每次的中位数都是q2的堆顶元素

#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
int ans[1007];
int main()
{
    int n, ind, num, cnt = 0, x;
    priority_queue< int,vector<int>,greater<int> > q1;//小堆,存放比q2都大的元素
    priority_queue< int,vector<int>,less<int> > q2;//大堆,存放小的元素
    scanf("%d", &n);
    while(n--)
    {
        cnt = 0;
        scanf("%d%d", &ind, &num);
        while(!q1.empty())q1.pop();
        while(!q2.empty())q2.pop();
        for(int i = 1; i <= num; i++)
        {
            scanf("%d", &x);
            if(q2.empty())q2.push(x);
            else{
                if(x > q2.top())q1.push(x);
                else q2.push(x);
            }
            //q2元素个数大于q1元素个数+1,将q2的堆顶元素给q1
            while(q2.size() - 1 > q1.size()) 
            {
                q1.push(q2.top());
                q2.pop();
            }
            //q2元素个数小于q1元素个数+1,将q1的堆顶元素给q2
            while(q2.size() - 1 < q1.size())
            {
                q2.push(q1.top());
                q1.pop();
            }
            if(i % 2 != 0)
            {
               ans[cnt++] =  q2.top();
            }
        }
        printf("%d %d\n",ind,cnt);
        for(int i = 0; i < cnt; i++)
            if(i % 10 == 9) printf("%d\n",ans[i]);
            else printf("%d ",ans[i]);
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值