poj2246 Matrix Chain Multiplication 矩阵连乘

   

Description

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices.
Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.
For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.
There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input

Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.
The second part of the input file strictly adheres to the following syntax (given in EBNF):
SecondPart = Line { Line } 

Line       = Expression 

Expression = Matrix | "(" Expression Expression ")"

Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125

 

      题意:先输入一个n,然后输入n个矩阵。接着就是输入矩阵算式。需要我们编程计算这个矩阵算式需要计算几次乘法。如果这个算式不能计算,就输出error,不然就输出计算次数。

   解析:1.因为矩阵有行跟列,所以最好要结构体来保存矩阵。

            2.如何表明一个矩阵,我的想法是用字母的下标来表示。如h[a-'A'].row

            3.如何来计算算是的优先顺序,这个是这个题目的难点。我的做法是用栈计算

         如果是'(',就跳过。如果是字母,我们就进栈。是')',就判断在栈顶的前两个能否相乘,如果l[top].r!=l[top-1].c,就是不能相乘,如果能相乘,次数等于l[top-1].c*l[top-1].r*l[top].c。矩阵变成行是l[top-1].c和列是l[top].r。

 

     代码:如下参考

 

 

#include <iostream>
#include <string.h>
using namespace std;
struct matrix
{
 int b,c;
}h[26],l[20];
int main()
{
 int n,i,m,top,sum;
 char f[100],a;
 cin>>n;
 for(i=0;i<n;i++)
 {
  cin>>a;
  cin>>h[a-'A'].b>>h[a-'A'].c;
 }
 while(cin>>f)
 {
  sum=0;top=-1;
  for(i=0;i<strlen(f);i++)
  {
   
   if(f[i]=='(')
    continue;
   else if(f[i]==')')
   {
    if(l[top].b==l[top-1].c)
    {
     
     sum+=l[top-1].b*l[top-1].c*l[top].c;
     l[top-1].c=l[top].c;
     top--;
    }
    else
    {
     cout<<"error"<<endl;
     break;
    }
    
   }
   else
   {
    l[++top].b=h[f[i]-'A'].b;
    l[top].c=h[f[i]-'A'].c;
   }
  }
  if(top==0)
   cout<<sum<<endl;
 }
 return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值