UVA_442: Matrix Chain Multiplication

42 篇文章 0 订阅

Description

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices.Since matrix multiplication is associative, the order in which multiplications are performed isarbitrary. However, the number of elementary multiplications needed strongly depends on theevaluation order you choose.For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).The first one takes 15000 elementary multiplications, but the second one only 3500.Your job is to write a program that determines the number of elementary multiplications needed fora given evaluation strategy.

Input

Input consists of two parts: a list of matrices and a list of expressions.The first line of the input file contains one integer n ( tex2html_wrap_inline28 ), representing the number ofmatrices in the first part. The next n lines each contain one capital letter, specifying the name of thematrix, and two integers, specifying the number of rows and columns of the matrix.The second part of the input file strictly adheres to the following syntax (given in EBNF):
SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output

For each expression found in the second part of the input file, print one line containing the word " error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125


分析:本题的关键是解析表达式。可以用一个栈来完成:遇到字母时入栈,遇到又括号时出栈计算,然后结果入栈。因为输入保证合法,括号无须入栈。遇到这种字符处理的题用c++写比较方便,而且不用考虑换行符,什么鬼都是一个string解决。


#include <iostream>
#include <stack>
#include <string>
#include <cstdio>
#include <cstring>

using namespace std;
struct mac{
	int x,y;
	mac(int x=0, int y=0):x(x),y(y) {}
};
mac macs[26];
stack<mac> stk;

int main()
{
	int n;
	cin >> n;
	for(int i=0; i<n; i++)
	{
		string j;
		cin >> j;
		int k = j[0]-'A';
		cin >> macs[k].x >> macs[k].y;
	}

	string op;
	while(cin >> op)
	{
		int cnt = 0; int error = 0;
		for(int i=0; i<op.length(); i++)
		{
            if(isalpha(op[i]))stk.push(macs[op[i]-'A']);
            else if(op[i]==')'){
				mac m2 = stk.top(); stk.pop();
				mac m1 = stk.top(); stk.pop();
				if(m1.y!=m2.x){error=1;break;}
				mac m; m.x = m1.x; m.y = m2.y;
				cnt += m1.x*m1.y*m2.y;
				stk.push(m);
            }
		}
		if(error){printf("error\n");while(!stk.empty())stk.pop();}
		else printf("%d\n",cnt);
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值