补题之路:POJ2566 Bound Found

题目描述

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: “But I want to use feet, not meters!”). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We’ll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.
You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

题意

给出无序数组和数t,求数组连续的一段的和与t最接近的是多少。
比如1,3,5,7,t=11时,输出12 3 4(最接近11的是5+7)

分析

前缀和数组排序,然后尺取选出最接近t的两项差

#include <iostream>
#include <algorithm>
using namespace std;
int n,k;
struct node {
 long long val,num,sum;
}spot[100005];
bool cmp(node a,node b){
 return a.sum<b.sum;
}
int main(){
 int t;
 while(cin >> n >> k && (n||k)){
  spot[0].val = 0,spot[0].sum = 0,spot[0].num = 0;
  for(int i = 1;i <= n;i++){
   cin >> spot[i].val;
   spot[i].sum = spot[i-1].sum+spot[i].val;
   spot[i].num = i;
  }
  sort(spot,spot+n+1,cmp);
  int min1,temp;
  
  while(k--){
   cin >> t;
   int p = 0,q = 1;
   min1=0x3f3f3f3f;
   int left,right;
   while(p<=n&&q<=n){
    
    int cha = spot[q].sum - spot[p].sum;
    if(cha < 0) cha = -cha;
    int cha1 = t-cha;
    if(cha1<0) cha1 = -cha1;
    if(cha1 < min1){
     min1 = cha1;
     temp = cha;
     left  = spot[p].num;
     right = spot[q].num;
    }
    if(cha < t)q++;
    else if(cha >t)p++;
    else break;
    if(p==q)q++;
   }
   if(left>right)
   swap(left,right);
   cout << temp << " " << left+1 << " " << right << endl;
  }
 }
 return 0;
}

坑点
记得cha==t要判断,一开始没写等于号改bug改了2小时qwqqqqqqqq

还有sort要从0开始

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值