POJ 2018-Best Cow Fences

Description

Farmer John’s farm consists of a long row of N (1 <= N <= 100,000)fields. Each field contains a certain number of cows, 1 <= ncows <= 2000.

FJ wants to build a fence around a contiguous group of these fields in order to maximize the average number of cows per field within that block. The block must contain at least F (1 <= F <= N) fields, where F given as input.

Calculate the fence placement that maximizes the average, given the constraint.
Input

  • Line 1: Two space-separated integers, N and F.

  • Lines 2..N+1: Each line contains a single integer, the number of cows in a field. Line 2 gives the number of cows in field 1,line 3 gives the number in field 2, and so on.
    Output

  • Line 1: A single integer that is 1000 times the maximal average.Do not perform rounding, just print the integer that is 1000*ncows/nfields.
    Sample Input

10 6
6
4
2
10
3
8
5
9
4
1
Sample Output

6500
Source

USACO 2003 March Green
.
.
.
.
.

分析

题意是在一个数组里,寻找一段连续和,使其平均和最大,但是长度不能小于F。
首先可以看出是满足单调性的,但是怎么二分呢,
我们先枚举一个可能的数。
然后数组里的值全部减去这个值(结果会有正有负),那么我们就看是否存一段长度大于等于F,且和为正。
.
.
.
.
.

程序:
#include<iostream>
#include<stdio.h>
double a[100001],b[100001],sum[100001],eps=1e-5,l=-1e6,r=1e6;
using namespace std;
int main()
{
    int n,L;
    cin>>n>>L;
    for (int i=1;i<=n;i++)
    scanf("%lf",&a[i]);
    while (r-l>eps)
    {
        double mid=(l+r)/2.0,ans=-1e10,min1=1e10;
        for (int i=1;i<=n;i++)
        b[i]=a[i]-mid;
        for (int i=1;i<=n;i++)
        sum[i]=sum[i-1]+b[i];
        for (int i=L;i<=n;i++)
        {
            min1=min(sum[i-L],min1);
            ans=max(ans,sum[i]-min1);
        }
        if (ans>=0) l=mid;else r=mid;
    }
    cout<<int(r*1000);
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值