大数相乘 java

9 篇文章 0 订阅
9 篇文章 0 订阅

Problem E: Product

Time Limit: 1 Sec  Memory Limit: 128 MB

Submit: 38  Solved: 25

[Submit][Status][Web Board]

Description

The problem is to multiply two integers X, Y. (0<=X,Y<10250)


 


Input

The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.


 


Output

For each input pair of lines the output line should consist one integer the product.


 


Sample Input

12

12

2

222222222222222222222222

Sample Output

144

444444444444444444444444

HINT

两个大数相乘,直到读到EOF(文件结尾)为止

1.首先,hasNext()是Scanner类的一个方法,判断是否有输入,有输入项,a .hasNext()为true,没有输入项,a.hasNext()为false。 这里就类似于c,c++里面的while(scanf("%d",&a)!=EOF)

2.大数的定义。

package sishuyan;
import java.math.BigInteger;
import java.util.Scanner;
public class Text {


public static void main(String[] args) {
  Scanner scan=new Scanner(System.in);
  while(scan.hasNext())
  {
  BigInteger a=scan.nextBigInteger();
  BigInteger b=scan.nextBigInteger();
  BigInteger c=a.multiply(b);
  System.out.println(c);
  }
}
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值