CF(0-1背包)

7 篇文章 0 订阅
6 篇文章 0 订阅

CF

Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description

LYD loves codeforces since there are many Russian contests. In an contest lasting for T minutes there are n problems, and for the ith problem you can get aiditi points, where ai indicates the initial points, di indicates the points decreased per minute (count from the beginning of the contest), and ti stands for the passed minutes when you solved the problem (count from the begining of the contest).
Now you know LYD can solve the ith problem in ci minutes. He can't perform as a multi-core processor, so he can think of only one problem at a moment. Can you help him get as many points as he can?

Input

The first line contains two integers n,T(0≤n≤2000,0≤T≤5000).
The second line contains n integers a1,a2,..,an(0<ai≤6000).
The third line contains n integers d1,d2,..,dn(0<di≤50).
The forth line contains n integers c1,c2,..,cn(0<ci≤400).

Output

Output an integer in a single line, indicating the maximum points LYD can get.

Sample Input
3 10
100 200 250
5 6 7
2 4 10
Sample Output
254

1.思路:

      (1)。假设每道题做出所需要的时间都为 t ,那么我们一定会选择单位时间内消耗最快的题目开始做,因为这样才能保证总的分数不会减少太快。假设每道题目不自动消耗分数,那么我们一定会选择题目越快做出越好。

于是,综合以上两种因素得出的公式便是 fi = di/ci ; 求得单位时间内减少速率,减少的快的优先选择。

      (2).然后接下来就是0-1背包的问题,时间t在这里就是背包的容量。

2.  注意:以前的背包都只是考虑它的价值,只考虑这一个方面,现在需要同时考虑减少的时间和解决问题的时间,在这里也就用引出了变量f.

#include <cstdio>
#include <iostream> 
#include <algorithm>
#include<cstring>
#include<stdlib.h>
using namespace std ; 
typedef struct thing{
int a;//某问题的总分 
int d;//减少的分值 
int c;//解决这个问题所需要花费的时间 
double f;//单位时间内,减少的分值 
}thing; 
thing th[100002];
int n,t;
long long dp[100002];//运行超时,也和数组定义的大小有关系 
bool cmp(thing a,thing b)
{

return a.f>b.f;
}
int main()
{
cin>>n>>t;
memset(dp,0,sizeof(dp));
for(int i=0;i<n;i++)
  cin>>th[i].a;
    for(int i=0;i<n;i++)
  cin>>th[i].d;
for(int i=0;i<n;i++)
{
  cin>>th[i].c;
  th[i].f=1.0*th[i].d/th[i].c;

sort(th,th+n,cmp);
  for(int i=0;i<n;i++)//表示得几个问题 
  {
  for(int j=t;j>=th[i].c;j--)//j表示已经过去的时间,已经过去分钟 
  {
   dp[j]=max(dp[j],dp[j-th[i].c]+th[i].a-th[i].d*j);
   //                t表示背包,减去第i个物品所花费的时间加上所得到的分值(也就是:题目中所说的ai-di*ti) 
}
  }
  long long num=0;
  for(int i=0;i<=t;i++)
     num=max(num,dp[i]);
cout<<num<<endl;
return 0;
  
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值