二分查找

Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X. 
 

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers. 
 

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO". 
 

Sample Input

 
   

 3 3 3

 1 2 3

 1 2 3

 1 2 3

 3 1 4 10

 

Sample Output

 
   
Case 1: 
NO
YES
NO

像这种查找类的题目,在比赛或者平时都考虑用二分查找,不要用暴力,因为数据太多,肯定会超时。
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	int a[500],b[500],c[500],ab[250000];
	int i,j,l,m,n,s,x,cas=0,p,flag;
	while(scanf("%d%d%d",&l,&m,&n)!=EOF)
	{
		for(i=0;i<l;i++)
			scanf("%d",&a[i]);
		for(i=0;i<m;i++)
			scanf("%d",&b[i]);
		for(i=0;i<n;i++)
			scanf("%d",&c[i]);
		p=0;
		for(i=0;i<l;i++)
			for(j=0;j<m;j++)
				ab[p++]=a[i]+b[j];
			scanf("%d",&s);
			sort(ab,ab+p);
			printf("Case %d:\n",++cas);
			while(s--)
			{
				scanf("%d",&x);
				flag=0;
				for(i=0;i<n;i++)  
				{
					int L=0,R=p-1,mid;  
					while(L<=R)  
					{
						mid=L+(R-L)/2;
						if(ab[mid]+c[i]==x)
						{
						  flag=1;
						  break;
						}
						if(ab[mid]+c[i]<x) L=mid+1;
						if(ab[mid]+c[i]>x) R=mid-1;
					}
					if(flag==1)break;
				}
				if(flag==1) printf("YES\n");
				else printf("NO\n");
			}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值