poj 2506 Tiling 大数 找规律 递推

14 篇文章 1 订阅
9 篇文章 0 订阅

Tiling

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9225 Accepted: 4385

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

1.首先得找出规律:该题目满足,a[i]=a[i-1]+a[i-2]*2;

2.因为数据太大的原顾,可以考虑用java 大数来做。

package javasishuyan;
import java.math.BigInteger;
import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
       Scanner scan=new Scanner(System.in);    
       BigInteger a,b,c,d;
       a=new BigInteger("1");
       b=new BigInteger("1");
       c=new BigInteger("3");
       while(scan.hasNext()){
    	   a=new BigInteger("1");
           b=new BigInteger("1");
           c=new BigInteger("3");
    	   int n=scan.nextInt();
    	   if(n==0)  System.out.println(a);
    	   if(n==1) System.out.println(b);
    	   if(n==2) System.out.println(c);
    	   else
    	   {
     		   for(int i=3;i<=n;i++){
     			   d=b.add(b);//这里相当于,a[i-2]*2;
     			   d=c.add(d);//这里相当于+a[i-1];
     			   b=c;
     			   c=d;
     		   }
     		   System.out.println(c);
    	   }
       }
  }
}

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值