poj 2187 Beauty Contest(凸包)

Description

Bessie, Farmer John's prize cow, has just won first place in a bovine beauty contest, earning the title 'Miss Cow World'. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 ... 10,000. No two farms share the same pair of coordinates. 

Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm 

Output

* Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other. 

Sample Input

4
0 0
0 1
1 1
1 0

Sample Output

2

给n个点,让求两个点距离的平方的最大值。凸包的模板题。


#include<cmath>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define LL long long
using namespace std;

const double eps = 1e-8;
struct Point
{
    double x,y;
    Point(){}
    Point(double _x,double _y)
    {
        x = _x;y = _y;
    }
    Point operator -(const Point &b)const
    {
        return Point(x - b.x,y - b.y);
    }
    double operator *(const Point &b)const
    {
        return x*b.x + y*b.y;
    }
    double operator ^(const Point &b)const
    {
        return x*b.y - y*b.x;
    }
};
bool cmp(Point a,Point b)
{
    if(a.x != b.x)
        return a.x < b.x;
    return a.y < b.y;
}
int sgn(double x)
{
    if(fabs(x) < eps)
        return 0;
    return x>0?1:-1;
}
vector<Point> convex_hull(vector<Point> p)
{
    sort(p.begin(),p.end(),cmp);
    int k = 0;
    vector<Point> v(2*p.size());
    for(int i=0;i<p.size();i++)
    {
        while(k > 1 && sgn((v[k-1] - v[k-2])^(p[i]-v[k-1])) <= 0)
            k--;
        v[k++] = p[i];
    }
    for(int i=p.size()-2,t=k;i>=0;i--)
    {
        while(k > t && sgn((v[k-1] - v[k-2])^(p[i]-v[k-1])) <= 0)
            k--;
        v[k++] = p[i];
    }
    v.resize(k-1);

    return v;
}
double dis(Point a,Point b)
{
    return (a.x-b.x)*(a.x-b.x) + (a.y-b.y)*(a.y-b.y);
}
vector<Point> p,v;
int main(void)
{
    int n,i,j;
    while(scanf("%d",&n)==1)
    {
        p.clear();
        v.clear();
        for(i=0;i<n;i++)
        {
            double x,y;
            scanf("%lf%lf",&x,&y);
            p.push_back(Point(x,y));
        }
        v = convex_hull(p);
        double ans = 0;
        for(i=0;i<v.size();i++)
        {
            for(j=i+1;j<v.size();j++)
            {
                ans = max(ans,dis(v[i],v[j]));
            }
        }
        printf("%d\n",(int)ans);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值