素数环

问题描述:<杭电1016>
Prime Ring Problem
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39510 Accepted Submission(s): 17415

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input
6
8

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

分析:
遍历所有1~n的排列,cur记录当前选择的第几个数。在遍历过程中满足不重复且为素数则进入下一个位置cur+1。直到cur==n。
代码:

#include <iostream>
#include <cmath>
using namespace std;

const  int MAXN = 30;
int a[MAXN];

int check(int cur,int n);
void PrimeCircle(int cur,int n);

int main()
{
    int n,i=1;
    while(cin>>n && n>0)
    {
        cout<<"Case "<<i++<<":"<<endl;
        a[0]=1;
        PrimeCircle(1,n);
        cout<<endl;
    }
    return 0;
}

void PrimeCircle(int cur,int n)
{
    if(cur == n)
    {
        for(int i=0;i<n-1;i++)
            cout<<a[i]<<" ";
        cout<<a[n-1];
            cout<<endl;
            return ;
    }
    for(int i=2;i<=n;i++)
    {
        a[cur] = i;
        int ok = 1;
        for(int j=0;j<cur;j++)
        {
            if(a[j]==a[cur])
            {
                ok = 0;
                break;
            }
        }
        if(check(cur,n)==0)
            ok = 0;
        if(ok)
        {
           PrimeCircle(cur+1,n);
        }
    }
}

int check(int cur,int n)
{
    int flag =1;
    int m = a[cur] + a[cur-1];
    int t = sqrt(m);
    for(int i=2;i<=t;i++)
    {
        if(m%i==0)
        {
            flag = 0;
            break;
        }
    }
    if(cur == n-1)
    {
        m = a[cur] + a[0];
        t =sqrt(m);
        for(int i=2;i<=t;i++)
        {
            if(m%i==0)
            {
                flag = 0;
                break;
            }
        }
    }
    return flag==1?1:0;

}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据引用\[1\]和引用\[2\]的代码,这是一个解决"素数"问题的算法。该问题要求找到一个由1到n这些数组成的,使得中相邻两个数之和都是素数。算法使用了深度优先搜索的思想,先选定一个数,然后递归地选择下一个数,直到找到一个满足条件的。在递归过程中,使用了一个数组来记录已经选择的数,以及一个布尔数组来标记是否已经访问过某个数。同时,还使用了一个函数来判断一个数是否是素数。 根据引用\[3\]的输出示例,当n=4时,可能的素数有8个,分别是: 1: 1 2 3 4 2: 1 4 3 2 3: 2 1 4 3 4: 2 3 4 1 5: 3 2 1 4 6: 3 4 1 2 7: 4 1 2 3 8: 4 3 2 1 因此,对于问题"1358 - 素数",当n=4时,总共有8个满足条件的素数。 #### 引用[.reference_title] - *1* [【DFS练习】素数](https://blog.csdn.net/z135733/article/details/122742948)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^insert_down28v1,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* *3* [1358 - 【提高】素数](https://blog.csdn.net/PanDaoxi2020/article/details/126597717)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^insert_down28v1,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值