Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 18638 Accepted: 7184
Description
A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.
So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.
Input
The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.
Output
For each test case, print on a line the number of squares one can form from the given stars.
Sample Input
4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0
Sample Output
1
6
1
Source
Rocky Mountain 2004
分析:
二分查找加暴力求解即可。
从所有点中取出两个点,把他们当做正方形的对角线上的点。中点为
x = (p[i].x+p[j].x)/2;
y = (p[i].y+p[j].y)/2;
xx=p[i].x-x;
yy=p[i].y-y;
所以另外两个点为:(x-yy,y+xx),(x+yy,y-xx))
将所有点排序后,用二分查找看另外两个点是否存在。
一个正方形有两条对角线,所以结果要/2.
AC代码:
#include <iostream>
#include <algorithm>
#include <vector>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
struct point
{
double x,y;
};
point p[1010];
int n;
bool cmp(point a,point b)
{
return (a.x<b.x || (a.x==b.x && a.y<b.y));
}
bool judge(double x,double y)
{
int low = 0,high = n-1,mid;
while(low<=high)
{
mid = (low+high)/2;
if(fabs(p[mid].x-x)<1e-9 && fabs(p[mid].y-y)<1e-9)
return true;
if(p[mid].x-x>1e-9 || (fabs(p[mid].x-x)<1e-9 && p[mid].y-y>1e-9))
high=mid-1;
else
low=mid+1;
}
return false;
}
int main()
{
while(scanf("%d",&n)!=EOF && n)
{
for(int i=0;i<n;i++)
{
scanf("%lf %lf",&p[i].x,&p[i].y);
}
sort(p,p+n,cmp);
int ans = 0;
double x,y,xx,yy;
for(int i=0;i<n;i++)
{
for(int j=i+1;j<n;j++)
{
x = (p[i].x+p[j].x)/2;
y = (p[i].y+p[j].y)/2;
xx=p[i].x-x;
yy=p[i].y-y;
if(judge(x-yy,y+xx) && judge(x+yy,y-xx))
{
ans++;
}
}
}
printf("%d\n",ans/2);
}
return 0;
}