(NYoj 230)彩色棒 --欧拉通路,字典树,并查集

题目: 彩色棒
时间限制:1000 ms | 内存限制:128000 KB
难度:5
描述
You are given a bunch of wooden sticks. Each endpoint of each stick is colored with some color. Is it possible to align the sticks in a straight line such that the colors of the endpoints that touch are of the same color?
输入
the frist line have a number k(0< k<=10),that is the number of case. each case contais a number m,then have m line, each line contains two words, separated by spaces, giving the colors of the endpoints of one stick. A word is a sequence of lowercase letters no longer than 13 characters. There is no more than 250000 sticks.
输出
If the sticks can be aligned in the desired way, output a single line saying Possible, otherwise output Impossible.
样例输入
1
5
blue red
red violet
cyan blue
blue magenta
magenta cyan
样例输出
Possible

分析:
这题是个典型的判断欧拉通路的问题。但是有几点要注意:
1:整个图要是连通的。我们用并查集解决
2:我们要将不同的颜色用不同的数字表示。由于棒的数量很大,不用map()我们用字典树解决。
3:满足欧拉通路的条件。记录顶点度数即可。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn=500010;
int p[maxn],d[maxn];
int id;

struct node
{
    node* next[26];
    int num;
    node()
    {
        for(int i=0;i<26;i++)
            next[i]=NULL;
        num=-1;
    }
};

int Trie(node * root, char* s)
{
    node* p=root;
    while(s[0]!='\0')
    {
        if(p->next[s[0]-'a']==NULL)
        {
            node* t=new node();
            p->next[s[0]-'a']=t;
            p=t;
        }
        else p=p->next[s[0]-'a'];
        s++;
    }
    if(p->num==-1)
        p->num=id++;
    return p->num;
}

void dfs(node* root)
{
    if(root==NULL) return ;
    for(int i=0;i<26;i++)
    {
        if(root->next[i]!=NULL)
        {
            dfs(root->next[i]);
        }
    }
    free(root);
}

int find(int x)
{
    return p[x]==-1?x:p[x]=find(p[x]);
}

void unit(int x,int y)
{
    int xx=find(x);
    int yy=find(y);
    if(xx!=yy)
        p[xx]=yy;
}

int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        char s1[15],s2[15];
        id=0;
        node* r = new node();
        memset(p,-1,sizeof(p));
        memset(d,0,sizeof(d));
        scanf("%d",&n);
        getchar();
        if(n==0)
        {
            printf("Possible\n");continue;
        }
        int a,b;
        for(int i=0;i<n;i++)
        {
            scanf("%s %s",s1,s2);
            a=Trie(r,s1);b=Trie(r,s2);
            d[a]++;d[b]++;
            unit(a,b);
        }
        dfs(r);
        bool flag=true;
        int k=find(0);
        for(int i=0;i<id;i++)
        {
            if(k!=find(i))
            {
                flag=false;break;
            }
        }
        if(!flag)
        {
            printf("Impossible\n");continue;
        }
        int num=0;
        for(int i=0;i<id;i++)
        {
            if(d[i]%2==1)
                num++;
            if(num>2)
                break;
        }
        if(num==0 || num==2)
            printf("Possible\n");
        else printf("Impossible\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
孪生素数是指两个素数之间的差值为2的素数对。通过筛选法可以找出给定素数范围内的所有孪生素数的组数。 在引用的代码中,使用了递归筛选法来解决孪生素数问题。该程序首先使用循环将素数的倍数标记为非素数,然后再遍历素数数组,找出相邻素数之间差值为2的素数对,并统计总数。 具体实现过程如下: 1. 定义一个数组a[N,用来标记数字是否为素数,其中N为素数范围的上限。 2. 初始化数组a,将0和1标记为非素数。 3. 输入要查询的孪生素数的个数n。 4. 循环n次,每次读入一个要查询的素数范围num。 5. 使用两层循环,外层循环从2遍历到num/2,内层循环从i的平方开始,将素数的倍数标记为非素数。 6. 再次循环遍历素数数组,找出相邻素数之间差值为2的素数对,并统计总数。 7. 输出总数。 至此,我们可以使用这个筛选法的程序来解决孪生素数问题。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [python用递归筛选法求N以内的孪生质数(孪生素数)](https://blog.csdn.net/weixin_39734646/article/details/110990629)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] - *2* *3* [NYOJ-26 孪生素数问题](https://blog.csdn.net/memoryofyck/article/details/52059096)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值