Cure 打表

Cure
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1473 Accepted Submission(s): 487

Problem Description
Given an integer n, we only want to know the sum of 1/k2 where k from 1 to n.

Input
There are multiple cases.
For each test case, there is a single line, containing a single positive integer n.
The input file is at most 1M.

Output
The required sum, rounded to the fifth digits after the decimal point.

Sample Input
1
2
4
8
15

Sample Output
1.00000
1.25000
1.42361
1.52742
1.58044

Source
2016 ACM/ICPC Asia Regional Qingdao Online

Recommend
wange2014 | We have carefully selected several similar problems for you: 5906 5905 5904 5903 5902

题意:

给你一个数字k 求1 + 1/4 + 1/9 …. + 1/(k^2)?

思路:

这个式子有个极限是 pi*pi / 6,如果只取前5位的话,那么k = 1000000的时候就可以达到了!

因此我们判断那个数字如果大于1000000 直接输出pi*pi/6的前五位!

否则 就打表计算!

坑:

注意 用字符串读取整数,会很长的= =!

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>
using namespace std;
typedef long long ll;
const int maxn = 1000000 + 10;
double sum[maxn];
void init(){
    sum[1] = 1.0;
    for (int i = 2; i < maxn; ++i){
        sum[i] = sum[i-1] + 1.0/((double)i*(double)i);
    }
}
char s[maxn];
int main(){
    init();
    while(scanf("%s",s) == 1){
        if (strlen(s) > 6){
            printf("%.5lf\n",sum[maxn-10]);
            continue;
        }
        int v = 0;
        for (int i = 0; s[i]; ++i)v = v*10 + s[i] - 48;
        printf("%.5lf\n",sum[v]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值