(HDU 1698)Just a Hook 线段树区间修改

Just a Hook
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 28817 Accepted Submission(s): 14276

Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
这里写图片描述
Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
Sample Input
1
10
2
1 5 2
5 9 3
Sample Output
Case 1: The total value of the hook is 24.

题意:
有一个n节的钩子,开始时都是铜的。每次可以修改一段区间中的所有钩子为铜,银,金色。每一节铜,银,金钩子的价值分别为1,2,3.问经过所有的修改后钩子的总价值为多少?

分析:
线段树区间修改问题。
每次在维护一段区间的价值时,我们先找到对底层将对应的区间彻底价值修改,然后在返回时顺便修改上层的区间价值。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 100005;
int sum[4*maxn],cur[4*maxn];
int t,n,m,l,r,c;

void build(int l,int r,int o)
{
    cur[o]=0;
    if(l == r)
    {
        sum[o] = 1;
        return ;
    }
    int m = (l+r)>>1;
    build(l,m,o<<1);
    build(m+1,r,o<<1|1);
    sum[o]=sum[o<<1]+sum[o<<1|1];
}

void update(int L,int R,int c,int l,int r,int o)
{
    if(L<=l && r<=R)
    {
        cur[o] = c;
        sum[o] = c*(r-l+1);
        return ;
    }
    int m = (l+r)>>1;

    if(cur[o])
    {
        cur[o<<1]=cur[o<<1|1]=cur[o];
        sum[o<<1]=cur[o]*(m-l+1);
        sum[o<<1|1]=cur[o]*(r-m);
        cur[o]=0;
    }
    if(L <= m) update(L,R,c,l,m,o<<1);
    if(R > m) update(L,R,c,m+1,r,o<<1|1);
    sum[o]=sum[o<<1]+sum[o<<1|1];
}


int main()
{
    int kase=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        build(1,n,1);
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&l,&r,&c);
            update(l,r,c,1,n,1);
        }
        printf("Case %d: The total value of the hook is %d.\n",kase++,sum[1]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值