(POJ3009)Curling 2.0 <DFS求最小步数>

87 篇文章 0 订阅
27 篇文章 0 订阅

题目链接:http://poj.org/problem?id=3009
Curling 2.0
Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.
这里写图片描述
The movement of the stone obeys the following rules:

At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
Once thrown, the stone keeps moving to the same direction until one of the following occurs:
The stone hits a block (Fig. 2(b), (c)).
The stone stops at the square next to the block it hit.
The block disappears.
The stone gets out of the board.
The game ends in failure.
The stone reaches the goal square.
The stone stops there and the game ends in success.
You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.
这里写图片描述
Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).
这里写图片描述
Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board

h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position
The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0
Sample Output

1
4
-1
4
10
-1
Source

Japan 2006 Domestic

题意:
在一个h*w的网格里,0表示空地,1表示障碍物,2表示起点,3表示终点。
每次可以向一个方向持续运动直到出现下面某种情况:
The stone hits a block (Fig. 2(b), (c)).撞击了一个障碍物
The stone stops at the square next to the block it hit.停在障碍物前一格
The block disappears.障碍物消失
The stone gets out of the board.The game ends in failure.出了网格,失败
The stone reaches the goal square.The stone stops there and the game ends in success.达到终点,游戏胜利
You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.最多移动10次

问:最少移动多少次,可以到达终点。注意:当某移动方向上相邻的格子为1时,该方向不能进行移动

分析:
我们用DFS直接进行搜索,不过每次要进行判断,和计算出停留的位置。
POJ题目的[Discuss]区是个好地方

AC代码:

#include <iostream>
#include <cstdio>
#define INF 0x3f3f3f3f
using namespace std;
const int MAX=22;

int map[MAX][MAX];
int  n,m;
int x1,y1,x2,y2;
int fx[]={1,-1,0,0};
int fy[]={0,0,1,-1};
int flag=0;
int step;
struct node
{
    int x,y;
}a;
bool move(int x,int y,int i)
{
    a.x=x,a.y=y;
    if(map[x][y]==3)
    {
        flag=1;
        a.x=x,a.y=y;
        return true;
    }
    if(x<1||x>n||y<1||y>m)
        return false;
    if(map[x][y]!=0)//方向上相邻的不能为1
        return false;
    while(1)
    {
        x+=fx[i];
        y+=fy[i];
        if(x<1||x>n||y<1||y>m)
            return false;
        if(map[x][y]==3)
        {

            flag=1;
            a.x=x,a.y=y;
            return true;
        }
        if(map[x][y]!=0)
        {
            return true;
        }
        a.x=x,a.y=y;
    }
}

void dfs(int x,int y,int ans)
{
    if(ans>10)
    {
        return ;
    }
    if(flag)
    {
        step=min(step,ans);
        return ;
    }

    for(int i=0;i<4;++i)
    {
        int tx=x+fx[i];
        int ty=y+fy[i];
        if(move(tx,ty,i)==false)
            continue;
        else
        {

            tx=a.x,ty=a.y;
            if(flag)
            {
                step=min(step,ans);
                return ;
            }
            map[tx+fx[i]][ty+fy[i]]=0;
            dfs(tx,ty,ans+1);
            map[tx+fx[i]][ty+fy[i]]=1;
            flag=0;
        }
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        if(m==0&&n==0)
            break;
        step=INF;
        flag=0;
        for(int i=1;i<=n;++i)
        {
            for(int j=1;j<=m;++j)
            {
                scanf("%d",&map[i][j]);
                if(map[i][j]==2)
                {
                    x1=i,y1=j;
                    map[i][j]=0;
                }
                if(map[i][j]==3)
                {
                    x2=i,y2=j;
                }
            }
        }
        dfs(x1,y1,0);
        if(step!=INF&&step<=9)
            printf("%d\n",step+1);
        else
            printf("-1\n");
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值