(POJ1905)Expanding Rods <几何+二分法(解方程)>

Expanding Rods
Description

When a thin rod of length L is heated n degrees, it expands to a new length L’=(1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced.
Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.
Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.
Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1
Sample Output

61.329
225.020
0.000
Source

Waterloo local 2004.06.12

题意:
有一个长为L的细杆固定在墙中间,当温度为n时,杆会膨胀到(1+n*C)*L的长度。问膨胀前后杆中心之间的距离?

分析:
所有条件题目都给了,我们利用集合知识求解。
这里写图片描述
做几条辅助线 从圆心做截线的垂线延长到弧 设棍子原长L 膨胀后(弧)长s 膨胀后中点与原中点距离h 半径r 半径与圆心到截线垂线的夹角θ 可以得到以下三个公式
sinθ = (L/2)/r
r^2 = (r-h)^2+(L/2)^2
s/(2*πr) = (2θ)/(2*π)
然后化简下 可得
θ = asin((L/2)/r)
r = ( L^2/(8*h) + h/2)
s = 2*θ*r = 2*asin((L/2)/r)*r
r只与h,L有关,s只与r,L有关。而L,S是已知的,所以问题就变成了解方程关于h的了:
s = 2*asin((L/2)/r)*r

用二分法解方程:
直接解上面的方程太难了,而h的方位是[0,L/2],所以我们可以用二分法来枚举h,看是否满足条件。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#define esp 1e-5
using namespace std;

int main()
{
    double L,C,s,r;
    int n;
    while(scanf("%lf%d%lf",&L,&n,&C)!=EOF)
    {
        if(L<0) break;
        s = L*(1.0 + n * C);
        double low,high,h;
        low = 0; high = L/2;
        while(high - low > esp)
        {
            h = (high + low)/2;A
            r = h/2 + (L*L)/(8 * h);
            if(2*asin(L/(2*r))*r < s) low = h;
            else high = h;
        }
        printf("%.3f\n",h);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值